2

I use "Lyx" as a Latex software. I have being using the Forward/Reverse search using SumatraPDF without a problem.

I used the approach described here: http://wiki.lyx.org/LyX/SyncTeX#toc1 I am using Sumatra PDF (on Windows), LyX Version 2.1.3 and MiKTeX 2.9 .

The first time I tried to use this Forward/backward tool, the forward search works, but the backward does not work, so I searched and find that I should change something in the converters (change pdflatex $$i to pdflatex -synctex=-1 $$i), and it worked.

I execute Forward search by right clicking in Lyx and choose "Forward search". For backward search I double left click in the PDF in Sumatra, a black "dos" window appears and vanishes quickly and that puts the cursor in approximately the wanted place in Lyx.

Forward/backward tool has been working great until last week where the Forward search stopped working: When I right click and choose "Forward search", another SumatraPDF window appears with a message: "error loading C:\Users\Me\AppData\Local\Temp\lyx_tmpdir.HQwWhzyr5240\lyx_tmpbuf0\myfile.pdf".

I didn't find anything in google about this error. I remember doing a Windows update before I had this problem so I suspect that it is the cause of this problem or maybe an update to SumatraPDF.

  • MikTeX or texlive? Which version of Lyx? How do you execute the forward search? Where there any solutions when you googled "lyx 'forward search' sumatrapdf"? – Keks Dose Mar 29 '15 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.