4

I found out that I can tweak hyphenation settings by writing:

\righthyphenmin=6
\lefthyphenmin=6
\usepackage{hyphenat}

I like this, because it hyphenates only really long words, leaving all others intact. But when I do \usepackage[ngerman]{babel}, hyphenation goes back to default settings.

I understand that when I load babel, it starts handling all the hyphenation and my settings mentioned above are not used anymore. How can I have a similar configuration while using babel? Maybe I can use some option, so that it will not change hyphenation settings?

(Side note: Normally I wouldn't use babel, but I need translated titles and captions for figures and lists.)

8

The babel documention states:

The macro \<lang>hyphenmins is used to store the values of the \lefthyphenmin and \righthyphenmin. Redefine this macro to set your own values, with two numbers corresponding to these two parameters.

So that would be:

\renewcommand\ngermanhyphenmins{66}
0

I found a simple solution:

\usepackage[ngerman=nohyphenation]{babel}
  • This setting won't let LaTeX hyphenate really long words, will it? – Mico Mar 27 '15 at 2:07
  • It does, using the hyphenat package. – mik01aj Mar 27 '15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.