2

I'm using TeX Live 2014 with kile as the editor. Usually I compile .tex files using kile's compilation button. There is no errors and no warnings, the output is complete.

When I compile the same file from the terminal, there is the warning (this is just the beginning of the terminal output):

warning: Could not open char translation file `utf-8.tcx'.
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
restricted \write18 enabled.

The output is different: there is no polish characters, the font looks different.

Here is the .tex file:

%& --translate-file=utf-8
\documentclass{article}

\usepackage{setspace}
\usepackage[polish]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\setlength{\parindent}{0pt}

\pagestyle{plain}

\begin{document}

\section[A]{Ab}

\subsection{B}

\textsc{F}: x \\*
\textsc{D}: xx\\*
\textsc{S}: xxx \\*

\vspace{1mm}

blablabla.
\vspace{2mm}

\emph{N?} \\*
śląź żań 
\vspace{2mm} 

\end{document}

Here is the screenshot of the .dvi output generated using terminal:

Here is the screenshot of the .dvi output generated using kile's compilation button:

When I compile the same file to .pdf via terminal, there is no font problems, even if the same warning appears.

I've found out this problem while trying to use latex2rtf, there are also problems with the .rtf files, so I'd like to make sure that the .tex file is fine.

UPDATE:

I've removed from the code the line %& --translate-file=utf-8. This time there is no warning, but stil the in output generated via terminal there are font problems. Pdf is stil fine.

  • You have dvi in the title and tagged the question dvi but you are using pdflatex, are you not generating pdf rather than dvi? – David Carlisle Mar 27 '15 at 14:28
  • You are using inputenc so don't want translation-file=utf-8 but I could not get your bad output in either case – David Carlisle Mar 27 '15 at 14:35
  • @DavidCarlisle Actually I'm calling latex and the terminal output begin with what I've put in my question, so pdfTeX, even if it generates .dvi file. The terminal output is the same if I run latex or pdflatex, just the output is different . – maria Mar 27 '15 at 14:44
  • latex is preloading the pdflatex format? That would be rather an unusual setup (possible though, and still possible to get dvi output by setting \pdfoutput to 0) but most distributions have separate formats for latex and pdflatex. – David Carlisle Mar 27 '15 at 15:14
  • I've installed TeXlive following the instructions from the Silex reply to question http://tex.stackexchange.com/questions/1092/how-to-install-vanilla-texlive-on-debian-or-ubuntu and I don't remember changing anything in kile's settings. I can still generate .pdf file. – maria Mar 27 '15 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.