2

I am using apacite for APA references in my thesis. It works beautifully with the exception that is displays the source type brackets in the reference list, which I don't want (see below). enter image description here Leaving the type field blank is not an option because I manage my bibliography in EndNote and then export it, which automatically fills this field in.

Below is a minimum working example.

\documentclass{article}
\usepackage[natbibapa]{apacite}

\begin{document}
\nocite{*}
\bibliography{sources.bib}
\bibliographystyle{apacite}

\end{document}

My .bib file is rather inconspicuous, but I am including it for completeness.

@article{mandelbrot1963variation,
author = {Mandelbrot, Benoît},
title = {The variation of certain speculative prices},
journal = {The Journal of Business},
volume = {36},
number = {4},
pages = {394-419},
year = {1963},
type = {Journal Article}
}

Suggestions are greatly appreciated!

  • 1
    Your example is not a working example: the bib is missing. – Ulrike Fischer Mar 27 '15 at 16:40
  • The command is \nocite{*}; what you've written is basically being treated as \nocite{*}{}, where the empty braces just add a space to an empty line. – jon Mar 27 '15 at 17:02
  • The type is as you see it already in the bbl ...{\BBCQ}\ [Journal Article], so you can get rid of it only by either changing the bst-file, or by manipulating the bib (you could do it with biber + sourcemap). With biblatex-apa it would be easy to get rid of it. – Ulrike Fischer Mar 27 '15 at 18:44
  • Doesn't my answer solve your problem? – karlkoeller Mar 29 '15 at 12:11
  • @karlkoeller, thank you for your answer. I was hoping there would be a way to do this without having to modify the .bst file and using apacite because I believe it conforms more exactly to APA style than BibLaTeX. – Constantin Mar 29 '15 at 12:15
3

OPTION #1: using a modified .bst file

First of all, from the command line, run

kpsewhich apacite.bst

to know where the file apacite.bst is. Its path should be TEXMF/bibtex/bst/apacite/.

Now copy apacite.bst in the directory where your .tex file is, and rename it to myapacite.bst.

Then open myapacite.bst in your editor, search for the lines

FUNCTION {format.atitle.type.check}
{ format.aetitle.check
  format.atype.check   connect.with.space.check
  title format.atitle.connect
}

and replace them with

FUNCTION {format.atitle.type.check}
{ format.aetitle.check
  title format.atitle.connect
}

Then search for the lines

FUNCTION {format.atitle.type.trans.check}
{ format.aetitle.check
  format.atype.check   connect.with.space.check
  format.atrans.check  connect.with.space.check
  title format.atitle.connect
}

and replace them with

FUNCTION {format.atitle.type.trans.check}
{ format.aetitle.check
  format.atrans.check  connect.with.space.check
  title format.atitle.connect
}

Save the file.

Now in your document, replace

\bibliographystyle{apacite}

with

\bibliographystyle{myapacite}

and you're done.

MWE

\begin{filecontents*}{sources.bib}
@article{mandelbrot1963variation,
author = {Mandelbrot, Benoît},
title = {The variation of certain speculative prices},
journal = {The Journal of Business},
volume = {36},
number = {4},
pages = {394-419},
year = {1963},
type = {Journal Article}
}
\end{filecontents*}

\documentclass{article}
\usepackage[natbibapa]{apacite}

\begin{document}
\nocite{*}
\bibliography{sources}
\bibliographystyle{myapacite}

\end{document} 

Output:

enter image description here


Note that you have

\bibliography{sources.bib}

in your MWE, but it should be

\bibliography{sources}

unless your .bib file is named sources.bib.bib....


OPTION #2: using biblatex-apa

Using biblatex with the apa style, the type field isn't printed by default.

Here's your MWE modified for using biblatex:

\begin{filecontents*}{sources.bib}
@article{mandelbrot1963variation,
author = {Mandelbrot, Benoît},
title = {The variation of certain speculative prices},
journal = {The Journal of Business},
volume = {36},
number = {4},
pages = {394-419},
year = {1963},
type = {Journal Article}
}
\end{filecontents*}

\documentclass{article}
\usepackage[american]{babel}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage[%
    style=apa,
    natbib=true,
    firstinits=true,
    uniquename=init,
    backend=biber]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

\addbibresource{sources.bib}

\begin{document}
\nocite{*}

\printbibliography

\end{document} 

Output:

enter image description here

  • Can you tell how to change the year from (2015) to just 2015? analogously, I tried searching the bst file for parentheses and similar, but found nothing! – Marie. P. Jan 12 '16 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.