3

The following MWE produces a Contents page with the roman page number in the footer centre. However, I try to set all the page number locations to be on the outside in both the frontmatter and main matter. This works for all front, main and back matter pages, but not for the ToC page. What causes this and how could it be fixed, i.e. placing the ToC page number on the outside of the page (right on a recto page, left on a verso page)?

\documentclass[article,twoside]{memoir}

\usepackage[pdfpagelayout=TwoColumnRight]{hyperref}

\makepagestyle{my}
\makeevenfoot{my}{\thepage}{}{}
\makeoddfoot{my}{}{}{\thepage}
\pagestyle{my}

\begin{document}
\frontmatter
\begin{titlingpage}
\ldots
\end{titlingpage}

\tableofcontents
\clearpage
\chapter{Front Matter Chapter}

\mainmatter
\chapter{Main Matter Chapter}
\end{document}
4

Add

\makeevenfoot{plain}{\thepage}{}{}
\makeoddfoot{plain}{}{}{\thepage}

to alter the plain page style which is used for the contents and similar pages.

  • 1
    Or just add \thispagestyle{my} After \tableofcontents. That is, if you want to keep the plain style the same for another purpose. – Christopher Mar 29 '15 at 0:13
  • 1
    @Christopher True. But the question did say this was wanted for all pages. I assumed that the contents was just the one-which-doesn't-work-so-far-discovered ;). – cfr Mar 29 '15 at 0:14
  • 1
    Indeed, I just came across it as an interesting option which could possibly come in handy. – Christopher Mar 29 '15 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.