2

I have this strange problem where at the bottom of a gantt chart extra information gets printed. The minimal working example below produces the following result for me.

enter image description here

\documentclass{report}
\usepackage{pgf}
\usepackage{pgfgantt}
\begin{document}
\begin{ganttchart}[time slot format=isodate-yearmonth, compress calendar]{2015-1-1}{2015-12-31}
\gantttitlecalendar{year,month}\\
\ganttbar{Item 1}{2015-1-1}{2015-6-1}\\
\ganttbar{Item 2}{2015-7-1}{2015-12-31}
\end{ganttchart}
\end{document}

Some information: TeXLive 2014.34872-1, LuaTeX beta-0.79.1, pgfgantt 2013/06/01 v4.0.

  • 1
    It is not extra garbage but simply garbage, unless a certain amount of garbage was expected! – Mariano Suárez-Álvarez Apr 2 '15 at 7:08
3

You are specifying the time slot specifier as {2015-1-1}{2015-12-31} i.e., yyyy-mm-dd. This corresponds to time slot format=isodate. When you specify time slot format=isodate-yearmonth, the tss format should be (yyyy-mm). So changing the tss to

{2015-01}{2015-12}

as in

\begin{ganttchart}[time slot format=isodate-yearmonth, compress calendar]{2015-01}{2015-12}

should solve your problem.

Code:

\documentclass{report}
\usepackage{pgf}
\usepackage{pgfgantt}
\begin{document}
\begin{ganttchart}[time slot format=isodate-yearmonth, compress calendar]{2015-01}{2015-12}
\gantttitlecalendar{year,month}\\
\ganttbar{Item 1}{2015-1-1}{2015-6-1}\\
\ganttbar{Item 2}{2015-7-1}{2015-12-31}
\end{ganttchart}
\end{document}

enter image description here

  • Thank you this solved my problem. I can additionally say that the today= option should also only be given in the yyyy-mm format or else it will produce similar problem. – im0 Apr 2 '15 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.