2

The title is probably too broad. The problem I face is that I am working on a beamer presentation, and because beamer conflicts with apacite, it has been suggested that biblatex be used instead. I have tried it but there are a few issues.

1) Full list of authors the first time, but uses "et al." in all subsequent cites, e.g. first time: (Doe, Smith, & Johnson, 2009); 2nd time and on: (Doe et al., 2009)

2) No comma between the authors and the year. How do I make it output something like (Smith and Johnson, 2009) instead of (Smith and Johnson 2009)?

5

I love biblatex. That said, in the following MWE beamer and apacite go together well.

\documentclass{beamer}

\usepackage{apacite}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A. and Buthor, B. and Cuthor, C.},
  year = {2001},
  title = {Alpha},
}
\end{filecontents}

\begin{document}

\begin{frame}{Some citations}
\cite{A01}

\cite{A01}
\end{frame}

\begin{frame}{Bibliography}
\bibliographystyle{apacite}
\bibliography{\jobname}
\end{frame}

\end{document}

EDIT: The same example with biblatex (using the style apa):

\documentclass{beamer}

\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A. and Buthor, B. and Cuthor, C.},
  year = {2001},
  title = {Alpha},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

\begin{frame}{Some citations}
\parencite{A01}

\parencite{A01}
\end{frame}

\begin{frame}{Bibliography}
\printbibliography
\end{frame}

\end{document}
  • Thanks! It's weird that I searched for "apa" in the biblatex.pdf (version 1.5a) and it didn't tell me that they have an "apa" style. Btw, I have a follow-up question. How do we make it do "Author, Buthor, & Cuthor (2001)"? – ceiling cat Jul 21 '11 at 11:06
  • 1
    The apa style is not provided by standard biblatex, but by the package biblatex-apa. – lockstep Jul 21 '11 at 15:15
  • Do you mean that you want to make the APA style do something other than it does or that the APA style has a problem? – PLK Jul 21 '11 at 17:22
  • I get error: ! Package biblatex Error: Option 'sorting=apa' invalid. when trying 2nd example. – ctrl-alt-delor Nov 7 '15 at 21:26
  • On BibLaTeX 3.4, I get the error ! Package biblatex Error: Option 'date=apalong' invalid. when trying 2nd example. Did anything change about apa style support? – glopes Sep 29 '16 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.