2

I'm using the fixme package to add notes to various parts of my thesis draft. However, if I set the margins using the geometry package, I notice that the fixme notes are not formatted correctly (with margin overflow). Is there a simple fix? MWE below:

\documentclass[letterpaper]{amsbook}
\usepackage[draft]{fixme}
\usepackage[lmargin=1.3in,rmargin=1.3in,bottom=1.3in,top=1.3in,twoside=False]{geometry}

\begin{document}
\listoffixmes


stuff \fixme{Here is where I would put a really long fixme note, so long in fact that it might seem silly....}

\end{document}
  • I have been using the todonotes package, and not familiar with fixme, but its not clear to me exactly what the problem is with the formatting of the output. – Peter Grill Jul 21 '11 at 7:31
4

There doesn't seem to be any problem; the "fixme" notes, for which the command \fxnote should be used instead of the deprecated \fixme, are typeset with the width of the normal marginal notes, which is the parameter \marginparwidth; indeed, adding

marginparwidth=0.5in

to the options passed to geometry typesets the note in a very narrow column.

2

Case 1

You use oneside and the default includemp which is false. The marginpar will be on the right side margin. In this case, you must make sure

marginparsep + marginparwidth < rmargin

enter image description here

\documentclass[draft,letterpaper,oneside]{amsbook}
\usepackage{fixme}
\usepackage
[
    %-------------------------------------------------------------------------------------------
    %
    %for symmetrical margin, just use margin instead of lmargin, rmagin, etc.
    margin=1.3in,
    %-------------------------------------------------------------------------------------------
    %
    %includemp=true,% uncomment this if you want the marginpar is placed inside the outer margin.
    %-------------------------------------------------------------------------------------------
    %
    %If you use oneside document and default includemp (which is false)
    %marginparwidth + marginparsep < rmargin
    marginparwidth=1in,
    marginparsep=0.2in
    %-------------------------------------------------------------------------------------------
]{geometry}

\def\dummy{I can find a tool to convert EPS to PDF in my neither bathroom nor kitchen.}
\usepackage{lipsum}

\begin{document}
\listoffixmes
\lipsum[1] 
\fixme{\dummy}
\lipsum[3]
\newpage
\lipsum[4] 
\fixme{\dummy}
\lipsum[6]
\end{document}

Case 2

You use oneside and includemp=true. The marginpar will be on the right side but it gets moved rmargin to the left. You must make sure that

marginparsep + marginparwidth < textwidth

enter image description here

\documentclass[draft,letterpaper,oneside]{amsbook}
\usepackage{fixme}
\usepackage
[
    %-------------------------------------------------------------------------------------------
    %
    %for symmetrical margin, just use margin instead of lmargin, rmagin, etc.
    margin=1.3in,
    %-------------------------------------------------------------------------------------------
    %
    includemp=true,%marginpar is placed inside the outer margin.
    %-------------------------------------------------------------------------------------------
    %
    %If you use oneside document and includemp = true
    %marginparwidth + marginparsep < textwidth
    marginparwidth=1.9in,
    marginparsep=0.1in
    %-------------------------------------------------------------------------------------------
]{geometry}

\def\dummy{I can find a tool to convert EPS to PDF in my neither bathroom nor kitchen.}
\usepackage{lipsum}

\begin{document}
\listoffixmes
\lipsum[1] 
\fixme{\dummy}
\lipsum[3]
\newpage
\lipsum[4] 
\fixme{\dummy}
\lipsum[6]
\end{document}
1

Adding a simplified answer in case it helps anybody, as it would have helped me:

There are two solutions. One is to add ignoremp=false to the options for geometry. This will cause the margins for the entire document to be expanded to fit the largest note - which is probably not desirable, unless you are planning to leave the fixme notes in place long term.

The other solution is to set marginparwidth= to a slightly smaller size than your right (or outer) margin. This sets the width that Fixme formats its notes to.

For example, this works for me:

\usepackage[
    top=2cm, bottom=3cm, inner=2cm, outer=3cm,
    marginparwidth=2cm %necessary to avoid breaking fixme notes.
    ]{geometry}
\usepackage[margin]{fixme}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.