2

I have trouble with a pie chart (pgf-pie). I can't put pie in block aside why?

\RequirePackage[absolute,overlay]{textpos}
\setlength{\TPHorizModule}{1cm}
\setlength{\TPVertModule}{1cm}
\newenvironment{aside}{%
  \let\oldsection\section
 \renewcommand{\section}[1]{
   \par\vspace{\baselineskip}{\Large\headingfont\color{pblue} ##1
}
  }
  \begin{textblock}{3.6}(2.0, 0.55)
  \begin{flushright}
  \obeycr
}{%
  \restorecr
  \end{flushright}
  \end{textblock}
  \let\section\oldsection


}

\begin{aside}
  \section{Personal Skills}
     \includegraphics[scale=0.62]{img/personal.png} 
        \begin{tikzpicture}%there is bug
            \pie [square]{40/A,30/B,20/C,10/D}
        \end{tikzpicture}
         ~
\end{aside}

output:

! LaTeX Error: Something's wrong--perhaps a missing \item.
See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...
l.64 ^^I^^I\begin{tikzpicture}
Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.
Missing character: There is no b in font nullfont!
Missing character: There is no l in font nullfont!
Missing character: There is no u in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no ! in font nullfont!
Missing character: There is no 6 in font nullfont!
Missing character: There is no 0 in font nullfont!
Missing character: There is no c in font nullfont!
Missing character: There is no y in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no ! in font nullfont!
Missing character: There is no 6 in font nullfont!
Missing character: There is no 0 in font nullfont!
Missing character: There is no y in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no l in font nullfont!
Missing character: There is no l in font nullfont!
Missing character: There is no o in font nullfont!
Missing character: There is no w in font nullfont!
Missing character: There is no ! in font nullfont!
Missing character: There is no 6 in font nullfont!
Missing character: There is no 0 in font nullfont!
Missing character: There is no o in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no g in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no ! in font nullfont!
Missing character: There is no 6 in font nullfont!
Missing character: There is no 0 in font nullfont!
! LaTeX Error: Something's wrong--perhaps a missing \item.
See the LaTeX manual or LaTeX Companion for explanation.
Type H <return> for immediate help.
...
l.65 ^^I^^I^^I\pie[square]{40/A,30/B,20/C,10/D}
Try typing <return> to proceed.
If that doesn't work, type X <return> to quit.

1 Answer 1

1

There's a lot of problems with this code:

  • no document class (no \documentclass command)
  • no \begin{document} and no \end{document}
  • \headingfont is undefined
  • pblue is not a defined color
  • the image is not found (your file img/personal.png is not available here)

The mentioned bug "Something's wrong--perhaps a missing \item." comes from the flushright environment. Remove it to see that. You could use \raggedleft later within the aside document text, or \hfill.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .