2

The cd package for tikz seems to be failing, or missing. I am using Kile in Ubuntu 10.4, and I installed all the tikz-related packages my package manager could find.

MWE:

\documentclass[a4paper,10pt]{article}
\usepackage[utf8]{inputenc}
\usepackage{tikz}
\usetikzlibrary{cd}


\begin{document}

bla

\end{document}
4
  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Have you got the file on your computer?
    – yo'
    Apr 6 '15 at 19:31
  • @yo' Thanks! No, I can't find the file either...
    – Gale
    Apr 6 '15 at 19:45
  • @Gale Which version of TikZ are you using? Would the package tikz-cd be feasible for you?
    – LaRiFaRi
    Apr 10 '15 at 7:21
  • @Gale does your error persist? Have you been able to update your version of TikZ?
    – LaRiFaRi
    Apr 29 '15 at 13:30
3

You need to install the tikz-cd package. It is not directly part of TikZ. Possibly not even part of your Linux package manager. You could get it from CTAN then.

Then, load the tikz-cd package:

\usepackage{tikz-cd}

But, alternatively, this should work then too:

\usepackage{tikz}
\usetikzlibrary{cd}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.