2

I am new in using MacTex and I use TexShop to compile LaTEX documents. I have many files in Vietnamese when I use Winshell (with MikTex) in Windows, and I transfer it to my MacBook. When I typerest the file, it run fine and the PDF export file show correctly. But in TexShop the Vietnamese for go wrong, It turn into something strange fonts. How should I do to let my old file with Vietnamese font from Winshell, appear correctly as in TexShop, in Macbook?

In Options tab of Winshell: Font: Times New Roman, Script: Vietnamese, Encoding: UTF-8

Sorry for my English, and MacTex, TeXShop are new for me.

  • 1
    Most probably a problem of text encoding. Which encoding did you use with Winshell? Also, it would be nice to produce a minimal (but complete) example of coding reproducing the problem. – Franck Pastor Apr 7 '15 at 5:09
  • Yes, that's exactly what I mean. In Options tab of Winshell: Font: Times New Roman, Script: Vietnamese, Encoding: UTF-8 – Jie Fan Apr 7 '15 at 6:44
3

From the comments, I deduce that TeXShop is not yet configured to UTF-8 text encoding. To do that, open the Preferences of TeXShop, select the “Document” panel (the first panel starting from the left), and select Unicode (UTF-8) in the Encoding section, like here (French version of TeXShop, but it should look close in other languages):

enter image description here

After this change, it could be necessary to quit and restart TeXShop to activate it.

If you want to do that on a per-file basis, insert this magic comment at the beginning of your .tex files:

% !TEX encoding = UTF-8 Unicode
| improve this answer | |
  • Haa, I solve it follows the above suggestion and set font Time New Roman. Thank you fpast! – Jie Fan Apr 7 '15 at 7:31
  • 1
    @ Hà Duy Hưng Hưng vote cho tác giả trả lời bằng cách bấm vào nút đầu ngòi bút phía trên nhé. – minthao_2011 Apr 7 '15 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.