8

Using this preamble:

\documentclass[pdftex,11pt,a4paper,openany]{memoir}
\usepackage[brazil]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{indentfirst}
\usepackage{latexsym}
\usepackage{amsmath,amssymb,amsfonts,wasysym}
\usepackage[pdftex]{graphicx}
\usepackage{wrapfig}
\usepackage[left=3cm,right=2cm,top=3cm,bottom=3cm]{geometry}
\usepackage{color}
\usepackage[dvipsnames]{xcolor}
\definecolor{darkgray}{gray}{0.3}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\usepackage[pdftex, colorlinks=true, linkcolor=darkgray, citecolor=blue, urlcolor=blue]{hyperref}

TexMaker gives this error message:

! LaTeX Error: Command \newfloat already defined.
Or name \end... illegal, see p.192 of the manual.

Where is the problem?

  • Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, then they are marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). – Caramdir Jul 21 '11 at 17:49
  • 3
    There's no error with the preamble you provided. If you are trying to load the package float afterwards, don't: memoir has its built-in mechanism for this. Never use the option pdftex. – egreg Jul 21 '11 at 18:04
  • Do you mean that I cant use memoir with pdftex? – Rodrigo Thomas Jul 21 '11 at 18:24
  • 1
    no, just that there is no reason to specify the pdftex option. Packages that respond to it will detect it by themselfs – daleif Jul 21 '11 at 18:51
10

There's no error with the preamble you provided. If you are trying to load the package float afterwards, don't: memoir has its built-in mechanism for defining new floating environments.

See p. 169 in the documentation.

5

Just for the record, I had the same problem, using memoir and floatrow together. Removing pdflatex from the preamble did not solve it.

I compiled the document successfully by adding the following line before loading floatrow:

\let\newfloat\undefined
\usepackage{floatrow}

Thanks to Joseph Wright.

  • thank you, it's worked for me – user200360 May 19 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.