1

I'm having an issue with the following code. The error is an undefined control sequence, the contents of the file does not matter on whether or not the error orcours. The error only exists on 1 computer even though the files are identical. I would very much like to know what could cause an error to exist on one computer and not another one even though the files are identical.

The error is as following:

LaTeX Warning: You have requested, on input line 235, version
               `2011/05/13' of package alphalph,
               but only version
               `2010/04/18 v2.3 Converting numbers to letters (HO)'
               is available.

! Undefined control sequence.
l.1149 \AtEndAfterFileList
                          {%

The code:

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[danish]{babel}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{fancyhdr}
\usepackage{lastpage}
\usepackage{pageslts}
\usepackage{hyperref}
\usepackage{float}
\usepackage[margin=2.5cm]{geometry}
\usepackage{caption}
\captionsetup[figure]{labelfont=bf, textfont=it}
\captionsetup[table]{labelfont=bf, textfont=it}
\usepackage{todonotes}
\usepackage{cancel}
\usepackage{placeins}
\pagestyle{fancy}

\cfoot{\theCurrentPage\,of \lastpageref{LastPages}}
\pagenumbering{arabic}

\begin{document}

\newpage
\begin{thebibliography}{99}
\bibliographystyle{plain}
\end{thebibliography}

\end{document}
2
  • 2
    Welcome to TeX.SX! A tip: If you indent lines by 4 spaces, like I've done in the edit, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). As the error message says, a package requires a 2011 version of a package, and on that computer you have only a 2010 version. Try to update your TeX distribution.
    – Astrinus
    Apr 7, 2015 at 12:11
  • 2
    I suspect that if you would run an update on the LaTeX installation on the computer with the compile error, it would go away. Suggestion: You should at least every 6 months update your LaTeX installation. Apr 7, 2015 at 12:14

1 Answer 1

2

The warning you provided explains where the problem lies. Namely, the package alphalph is out of date and updating it should fix the error.

See How do I update my TeX distribution? on how to update the package(s).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.