I try to set up the left and right margins to 1 inch, top and bottom margins to 0.5 inch. The following is my code:

% Setup the margin
\usepackage[centering, margin={1in, 0.5in}, includeheadfoot]{geometry}

But I don't know why the result doesn't show me the correct page setup.

enter image description here

As you can see, obviously the bottom margin is 0 and the footer is missing. That's not what I set up. Could anybody tell me what's wrong with my code? and how to fix it? Thank you very much.

1 Answer 1


Because you overrode the default settings defined by the geometry package (such as \footskip) then the last settings will be applied to take effect. You set \footskip to 25pt and that is too small!

I recommend that you use geometry's settings only rather than mixing them with native length macros. The following native length macros should not be used if you have already loaded the geometry package.


The link How to avoid getting cropped marginpar? and the following code snippet may help you to understand how to set up the page layout.

        a4paper,% other options: a3paper, a5paper, etc
        % use vmargin=2cm to make vertical margins equal to 2cm.
        % us  hmargin=3cm to make horizontal margins equal to 3cm.
        % use margin=3cm to make all margins  equal to 3cm.

If you need more, drop a comment.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .