2

I've decided to switch to LuaLaTeX for superior font support and built-in programming capabilities, but I cannot produce any output. It does not even generate a .log or .aux file. I've come across the thread LuaLaTeX: No error but no output files and followed the instructions therein, but it did not solve the problem.

Configuration:

  • Windows 8.1 64-bit (build 9600)
  • MiKTeX 2.9.4503 (64-bit)
  • LuaTeX version: beta-0.79.1 (rev 4971)

Minimum example:

\documentclass{article}
\begin{document}
This will not compile.
\end{document}

Steps taken:

  1. Enabled the lualatex and luatex formats in MiKTeX options and built all format files.
  2. Updated MiKTeX and rebuilt all format files.
  3. Tried invoking lualatex from command line (normally I use TeXnicCenter). The only result I get is the text 'This is LuaTeX, Version beta-0.79.1 (MiKTeX 2.9 64-bit) (rev 4971)', but no .pdf, .aux or .log files are produced.

Your help is greatly appreciated.

  • Welcome to TeX.SX! I get the suspected (working) result on Linux, TeXLive 2014 – user31729 Apr 8 '15 at 11:33
  • Sounds as if the format is not correct. How did you rebuild the formats? With miktex settings or with miktex settings (admin)? – Ulrike Fischer Apr 8 '15 at 11:39
  • @Christian Hupfer: Thank you. It must be MiKTeX-specific then. – tethered.sun Apr 8 '15 at 11:41
  • @Ulrike Fischer: Thank you. I used MiKTeX settings (admin). – tethered.sun Apr 8 '15 at 11:42
  • 1
    Then try again with the user miktex settings. If you have a user format it takes precedence and the admin tools can't overwrite it. – Ulrike Fischer Apr 8 '15 at 11:44
3

You need to recreate the lualatex format.

Try first to do it with miktex-settings (admin). If this doesn't help you probably have a format in your user profile which takes precedence and which the admin tools can't overwrite. In this case you must recreate the format with the user miktex-settings.

  • I tried to extend the minimum example a bit with fontspec and immediately I ceased to get any output. Now .log files are generated but .aux files are not. I cannot find any error in the log file. When I run lualatex in the command line, the feedback does end with '*** MultiByteToWideChar() failed for some reason', but this text does not appear in the log. The log stops at the line before that. – tethered.sun Apr 8 '15 at 12:20
  • 2
    Don't add new questions in a comment. Create a new question and don't forget to show a complete minimal example. – Ulrike Fischer Apr 8 '15 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.