4

Lohit Tamil Classical font that I am using with Xelatex does not have a glyph for superscript 4. (please see https://github.com/pravins/lohit/issues/68)

I have tried using ucharclasses for automatic switching to a different font for superscripts, but it is not working.

This is what I have in my preamble:

\defaultfontfeatures{Mapping=tex-text,Scale=MatchLowercase}
\setmainlanguage{english}
\setotherlanguage{tamil}
\setmainfont{FreeSerif}[Scale=1]
\newfontfamily{\englishfont}[Scale=1.05]{FreeSerif}
\newfontfamily{\tamilfont}[Scale=1,Script=Tamil,Language=Tamil]{FreeSerif}
\newfontfamily{\tamilfont}[Scale=1,Script=Tamil]{Lohit Tamil Classical}

\usepackage[Latin, Tamil, SuperscriptsandSubscripts]{ucharclasses}
\setTransitionTo{SuperscriptsandSubscripts}{\normalfont}
\setTransitionFrom{SuperscriptsandSubscripts}{\tamilfont}
\setTransitionTo{Tamil}{\tamilfont}
\setTransitionFrom{Tamil}{\normalfont}
\setTransitionsFor{Latin}
  {\hyphenrules{english}\normalfont}
  {\hyphenrules{sanskrit}\tamilfont}
\setTransitionsFor{Tamil}
  {\hyphenrules{sanskrit}\tamilfont}
  {\hyphenrules{english}\normalfont}
%

and here is a sample of text from the document.

\section{அத² ஷட³ஸ்த்ரிம்ஶ: படல:}

ஶ்ரீஆனந்த³பை⁴ரவீ உவாச
அத² காந்த ப்ரவக்ஷ்யாமி குண்ட³லீசேதனாதி³கம் ।
ஸஹஸ்ரநாமஸகலம் குண்ட³லின்யா: ப்ரியம் ஸுக²ம் ॥ 36-1॥

அஷ்டோத்தரம் மஹாபுண்யம் ஸாக்ஷாத் ஸித்³தி⁴ப்ரதா³யகம் ।
தவ ப்ரேமவஶேனைவ கத²யாமி ஶ்ருʼணுஷ்வ தத் ॥ 36-2॥

Edit:

Here is an MWE, please let me know how I can get it to display the 4 superscript. Thanks!

\documentclass[a5paper,11pt,twoside,onecolumn,openany,final]{memoir}
\usepackage[a5paper,hmargin=0.7in,vmargin=0.75in]{geometry}
\usepackage{multicol,polyglossia,fontspec,etoolbox}
%
\defaultfontfeatures{Mapping=tex-text}
\setmainlanguage{english}
\setotherlanguage{tamil}
\setmainfont{FreeSerif}[Scale=1]
\newfontfamily{\englishfont}[Scale=1.05]{FreeSerif}
\newfontfamily{\tamilfont}[Scale=1,Script=Tamil]{Lohit Tamil Classical}
%
\usepackage[Latin, Tamil]{ucharclasses}
\setTransitionTo{SuperscriptsandSubscripts}{\normalfont}
\setTransitionFrom{SuperscriptsandSubscripts}{\tamilfont}
\setTransitionTo{Tamil}{\tamilfont}
\setTransitionFrom{Tamil}{\normalfont}
\setTransitionsFor{Latin}
  {\hyphenrules{english}\normalfont}
  {\hyphenrules{tamil}\tamilfont}
\setTransitionsFor{Tamil}
  {\hyphenrules{tamil}\tamilfont}
  {\hyphenrules{english}\normalfont}
%
\begin{document}
\section{அத² ஷட³ஸ்த்ரிம்ஶ: படல:}

ஶ்ரீஆனந்த³பை⁴ரவீ உவாச
அத² காந்த ப்ரவக்ஷ்யாமி குண்ட³லீசேதனாதி³கம் ।
ஸஹஸ்ரநாமஸகலம் குண்ட³லின்யா: ப்ரியம் ஸுக²ம் ॥ 36-1॥

அஷ்டோத்தரம் மஹாபுண்யம் ஸாக்ஷாத் ஸித்³தி⁴ப்ரதா³யகம் ।
தவ ப்ரேமவஶேனைவ கத²யாமி ஶ்ருʼணுஷ்வ தத் ॥ 36-2॥

வினா யஜனயோகே³ன வினா த்⁴யானேன யத்ப²லம் ।
தத்ப²லம் லப⁴தே ஸத்³யோ வித்³யாயா: ஸுக்ருʼபா ப⁴வேத் ॥ 36-3॥
\end{document}
4

The option is SuperscriptsAndSubscripts (note the uppercase A).

Here I use a Tamil font I have on my machine.

For the transitions to/from superscripts, it's better to go with \begingroup\normalfont and \endgroup, so this will work independently on the context.

\documentclass{article}
\usepackage{fontspec,polyglossia}
\defaultfontfeatures{Mapping=tex-text,Scale=MatchLowercase}
\setmainlanguage{english}
\setotherlanguage{tamil}
\setmainfont{FreeSerif}[Scale=1]
\newfontfamily{\englishfont}[Scale=1.05]{FreeSerif}
\newfontfamily{\tamilfont}[Scale=1,Script=Tamil,Language=Tamil]{InaiMathi}
%\newfontfamily{\tamilfont}[Scale=1,Script=Tamil]{Lohit Tamil Classical}

\usepackage[Latin, Tamil, SuperscriptsAndSubscripts]{ucharclasses}
\setTransitionTo{SuperscriptsAndSubscripts}{\begingroup\normalfont}
\setTransitionFrom{SuperscriptsAndSubscripts}{\endgroup}

\setTransitionTo{Tamil}{\tamilfont}
\setTransitionFrom{Tamil}{\normalfont}
\setTransitionsFor{Latin}
  {\hyphenrules{english}\normalfont}
  {\hyphenrules{sanskrit}\tamilfont}
\setTransitionsFor{Tamil}
  {\hyphenrules{sanskrit}\tamilfont}
  {\hyphenrules{english}\normalfont}
%

\begin{document}

\section{அத² ஷட³ஸ்த்ரிம்ஶ: படல:}

ஶ்ரீஆனந்த³பை⁴ரவீ உவாச
அத² காந்த ப்ரவக்ஷ்யாமி குண்ட³லீசேதனாதி³கம் ।
ஸஹஸ்ரநாமஸகலம் குண்ட³லின்யா: ப்ரியம் ஸுக²ம் ॥ 36-1॥

அஷ்டோத்தரம் மஹாபுண்யம் ஸாக்ஷாத் ஸித்³தி⁴ப்ரதா³யகம் ।
தவ ப்ரேமவஶேனைவ கத²யாமி ஶ்ருʼணுஷ்வ தத் ॥ 36-2॥

\end{document}

enter image description here

  • The above works fine with article. For memoir, I had to remove the \begingroup and \endgroup - as it was causing the error 'extra \endgroup' – shreeshrii Apr 9 '15 at 15:06
  • @shreeshrii I have no error if I change article into memoir – egreg Apr 9 '15 at 16:28
  • In my document along with memoir class, I have a lot of other commands in the preamble. Maybe, there was a conflict with one of those. – shreeshrii Apr 10 '15 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.