1

Here's my tex file:

\documentclass{article}

\bibliographystyle{bmc-mathphys}
\begin{document}
\nocite{JEF_5G}
\bibliography{my_ref}
\end{document}

Below is bib:

@PREAMBLE{}

@String { AER  = {American Economic Review} }
@String { JIMF = {Journal of International Money and Finance} }


@Article{JEF_5G,
  Title                    = {What Will {5G} Be?},
  Author                   = {Jeffrey G. Andrews and Stefano Buzzi and Wan Choi and Stephen Hanly and Angel Lozano and Anthony C. K. Soong and Jianzhong Charlie Zhang},
  Journal                  = {IEEE J. Sel. Areas Commun., Special Issue on 5G Communication Systems},
  Year                     = {2014},
  Note                     = {{{doi}: 10.1109/JSAC.2014.2328098}},
  Number                   = {6},
  Pages                    = {1065-1081},
  Volume                   = {32},

  Owner                    = {kenadams},
  Timestamp                = {2014.08.14}
}
2
  • Your MWE is incomplete, see Using option for bibliography style
    – Fato39
    Apr 10, 2015 at 9:23
  • Or not perhaps. I'm not familiar either with this bibliography style or document class, but managed to get author-year citation nevertheless. See my answer.
    – Fato39
    Apr 10, 2015 at 9:42

1 Answer 1

2

To quote from bmc-mathphys.bst:

% Settings:
% It's possible to pass few options to bibtex style via @settings reference. 
% To validate options, need to write that reference (@settings) citeing key (f.e: \citation{foo}) 
% to aux file. From tex file it can be done with \nocite{} command.
%
% Examples:
%     1) To make unsorted bibliography (bibs listed as cited)  
%         a) write to bib file:
%             @settings{label, options="unsort"}
%         b) write in tex file \nocite{label}
%     
%     2) To make author-year bibliography
%         a) write to bib file:
%             @settings{label, options="nameyear"}
%         b) write in tex file \nocite{label}
%     
%     3) To make alphanumerical unsorted bibliography (bibs listed as cited)  
%         a) write to bib file:
%             @settings{label, options="alpha,unsort"}
%         b) write in tex file \nocite{label}
% 
% By default, style produces unsorted bibliography.

Following the instructions under 2), I get with your MWE: MWE compiled

However, LuaLaTeX produces a non-fatal error. You haven't specified what (bibliography) compiler you are using, so I haven't investigated further.

9
  • I'm using a WinEDT.
    – jeecabz
    Apr 11, 2015 at 5:30
  • @jeecabz WinEDT is a (LaTeX editor)[tex.stackexchange.com/questions/339/latex-editors-ides]. I was wondering what compiler you use, when you want to produce the final document (usually DVI od pdf). Some of the popular options are: pdfLaTeX, XeTeX, LuaLaTeX. Additionally, have you tried my solution? Did it work for you?
    – Fato39
    Apr 11, 2015 at 8:14
  • 1
    I used pdflatex then bibtex in generating bbl file..
    – jeecabz
    Apr 14, 2015 at 4:38
  • 1
    Now, I found out.. %%%%% setting default options FUNCTION {set.default.opt} {"nameyear" 'list.string :=}
    – jeecabz
    Apr 15, 2015 at 7:41
  • 1
    @Fato39, yes I think so too. The compiler pointed the command, which causes the warning, is \nocite{label}. Because in the bib file there is no citation entry that labelled label. For now, I ignored the warnings.
    – Aryo
    Jan 16, 2021 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.