\usepackage{url, cite, datetime, filecontents}

\title{Bare Demo of IEEEtran.cls for Conferences}

\IEEEspecialpapernotice{(last revised: \today)}

    title = {Iterative deconvolution and semiblind deconvolution methods in magnetic archaeological prospecting},
    volume = {74},
    issn = {0016-8033, 1942-2156},
    url = {http://library.seg.org/doi/abs/10.1190/1.3129263},
    doi = {10.1190/1.3129263},
    number = {4},
    urldate = {2014-01-24},
    journal = {GEOPHYSICS},
    author = {Zunino, Andrea and Benvenuto, Federico and Armadillo, Egidio and Bertero, Mario and Bozzo, Emanuele},
    month = jul,
    year = {2009},
    pages = {L43--L51}


The abstract goes here.

Not a convoluted \cite{zunino_iterative_2009}\ldots example

\bibliography{IEEEabrv, \jobname}


I've also tried with the following blocks:

  • \begin{*filecontents}{\jobname.bib}\end{*filecontents}

Additionally I've tried putting the filecontents lines above the \bibliography line.

And to replace that bibliography line I've tried these:

  • \bibliography{IEEEabrv, \jobname}
  • \bibliography{IEEEabrv}
  • \bibliography{}
  • \begin{thebibliography}\end{thebibliography}
  • \bibliographystyle{ieeetran}\bibliography{references}


  • MiKTeX-pdfTeX 2.9.5496 (1.40.15) (MiKTeX 2.9 64-bit)
  • MiKTeX Compiler Driver 2.9.5497 (MiKTeX 2.9 64-bit)

(TeXworks - texify --pdf --tex-option=$synctexoption $fullname - pdfLaTeX+MakeIndex+BibTeX)


Unfortunately no matter which of these I try, no bibliography is generated and next to the citation it just says [?].

  • 1
    Whitespace found in line xy, delete the whitespace in the argument of bibliographgy and set a bibliographystyle. \bibliographystyle{IEEEtran}\bibliography{\jobname}
    – Johannes_B
    Apr 12, 2015 at 11:35
  • @Johannes_B OP seems to agree this is the solution, do you want to write one up? Alternatively, there might be a duplicate (didn't find one, but didn't really look either).
    – moewe
    Apr 12, 2015 at 12:15
  • @moewe didn't find a dupe either, i'll write something up.
    – Johannes_B
    Apr 12, 2015 at 12:18
  • Sorry I do not quite understand from the question what do you want to achieve. For example, does amsrefs do what you need? Apr 12, 2015 at 15:50

1 Answer 1

\section{Polka loving Platypus}
\bibliography{xampl, biblatex-examples}

Running bibtex on the aux file of the first LaTeX run gives us the following

    The style file: alpha.bst
    White space in argument---line 5 of file atInlineBib.aux
     : \bibdata{xampl,
     :                 biblatex-examples}
    I'm skipping whatever remains of this command

This tells us, we need to remove the space in the argument of \bibliography to get BibTeX satisfied. In the end, we will see the the expected result.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .