4

I'm trying to get this output through biblatex,

“Prospects of Slavery Expansion,” Charleston Mercury. In The Causes of the Civil War, edited by Kenneth Stampp, 148-49. New York: Touchstone, 1991.

The problem is there is no author, it goes title of article in book / the source from a newspaper / book / editor / page number so on.

@misc just seems to garble it all up, it's supposed to be in Chicago style like this reference.

I should add I'm just looking for the .bib entry, I looked through the wiki book guide and I couldn't find a solution.

These are the packages I'm using for the Chicago style:

\usepackage[english]{babel}
\usepackage{csquotes}
\usepackage[utf8]{inputenc}
\usepackage[authordate, notes ,backend=biber]{biblatex-chicago}

I've been mucking around with the .bib entry, I honestly don't know how to approach it but this is the non-functional entry so far:

@misc{mercury,
title = "Prospects of Slavery Expansion",
volume = "Charleston Mercury",
booktitle     = "The Causes of the Civil War",
date = "1991",
publisher    = "Touchstone",
editor           = "Kenneth Stampp",
location       = "New York",
}
  • 1
    Welcome to TeX.SE. Please post the full bib entry that's giving you trouble, and please state exactly which bibliography style you use -- there are quite a few bst files that claim to implement "Chicago-style" formatting. – Mico Apr 13 '15 at 13:49
  • If your snippet says the truth the title of your question and the tag is wrong as you are using biblatex and biber and not bibtex. – Ulrike Fischer Apr 13 '15 at 13:59
  • Ok, tags and title are fixed – user2323423 Apr 13 '15 at 14:11
  • 2
    I'm pretty sure @misc is the wrong entry type here, but I'm certain you can't (and shouldn't) use authordate for any style where the year is meant to come at the end of the entry: that's the traditional Chicago 'notes and bibliography' (option notes) style. But I think you want to look at the @inbook entry type ... though I don't understand how something has a "title of article in book / the source from a newspaper". – jon Apr 13 '15 at 14:26
  • 1
    Hmm, in my opinion, then, if you've only looked at the article (yourself, directly), then you should only cite the article in the sense that it's what should appear in the bibliography. An explanatory aside in the relevant footnote can explain the relationship to the original source (which doesn't need to be cited: surely the article explains how to find the original source). Otherwise, you're going to need to create two entries and link them via crossref or xref. – jon Apr 13 '15 at 15:34
2

You state that this entry has no author. However, functionally speaking, "Charleston Mercury" is the author of the piece. Since it's a "corporate author", the field should be

author = {{Charleston Mercury}},

(note the double curly braces) to assure that the entry will not be (mis)interpreted as having been written by a person whose first name was "Charleston" and surname was "Mercury".

If you wanted to adopt the convention of italicizing the second part of the newspaper's name ("New Orleans Bee" "Chicago Tribune", etc), you'd write

author = {{Charleston \emph{Mercury}}},

Incidentally, it might be helpful to provide the salient information for the chapter and pages fields of this publication as well.

enter image description here

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents}{newbibl.bib}
@incollection{mercury,
   author = {{Charleston Mercury}},
   title  = {Prospects of Slavery Expansion},
   chapter   = {50},
   pages     = {148--149},
   booktitle = {The Causes of the Civil War},
   date      = {1991},
   publisher = {Touchstone},
   editor    = {Kenneth Stampp},
   location  = {New York},
}
\end{filecontents}
\usepackage[english]{babel}
\usepackage{csquotes}
\usepackage[utf8]{inputenc}
\usepackage[authordate, notes ,backend=biber]{biblatex-chicago}
\bibliography{newbibl}

\begin{document}
\nocite{*}
\printbibliography
\end{document}
0

Ok I've found a pretty rough and ready solution for this

Thanks to everyone for the assistance

I've basically switched around the title and author fields of the .bib file and added formatting changes where necessary, here is the .bib

@incollection{mercury,
title = {Charleston Mercury},
author = {{\enquote{Prospects of Slavery Expansion}\nopunct }},
booktitle     = {The Causes of the Civil War},
date = {1991},
publisher    = {Touchstone},
editor           = {Kenneth Stampp},
location       = {New York},
options       = {useeditor=false},
}

and in the .tex I removed quotation marks around the title (as it's pulled a switcheroo with the author field)

\DeclareFieldFormat[incollection]{title}{#1}
\DeclareFieldFormat[incollection]{citetitle}{#1}

this wont work if I wanted more incollection references but as that isn't a problem for this document thats fine for now.

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.