2

I'm using the memoir class, which has the option to directly define what should be shown on odd and even pages, seperately. I want to put the page number on the left of the left pages, and on the right of the right pages. Just like a regular book.

But somehow, it's not working. This is my preamble:

\documentclass[a4paper,oneside,article]{memoir}

\usepackage[utf8]{inputenc}
\usepackage[danish]{babel}
\usepackage{microtype}
\usepackage{lipsum}

\usepackage[danish]{varioref}

\usepackage{amsmath,amssymb}
\usepackage{bm}
\usepackage{amsthm}
\usepackage{mathtools}
\usepackage{icomma}

\usepackage{listings}

\usepackage{siunitx}

\usepackage{graphicx}
\graphicspath{{billeder/}}

\usepackage[version=3]{mhchem}

\usepackage{color,soul}

\usepackage{lastpage}

\usepackage{threeparttable}
\usepackage{multirow}

\usepackage[includeheadfoot,left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\makepagestyle{standard}
\makeevenhead{standard}{}{}{}
\makeoddhead{standard}{}{}{}
\makeevenfoot{standard}{Page \thepage\ of \pageref{LastPage}}{}{AO, DA, NFL}
\makeoddfoot{standard}{AO, DA, NFL}{}{Page \thepage\ of \pageref{LastPage}}
\makeheadrule{standard}{\textwidth}{\normalrulethickness}
\makefootrule{standard}{\textwidth}{\normalrulethickness}{3pt}
\setlength{\headheight}{40pt}
\pagestyle{standard}

\begin{document}

\author{AO, DA, NFL}
\title{Title}
\date{2015.06.01}
\maketitle
\pagebreak
\tableofcontents*
\pagebreak

\lipsum
\lipsum
\lipsum

\end{document}

Can anyone tell me what I'm doing wrong?

From the answers I've gotten so far, i've changed the argument of "oneside" in the very first line to "twoside", and it works. But as described below, now, the title page and ToC has changed. These are snapshots of oneside titlepage and ToC, and twoside twoside titlepage and ToC.

Oneside, titlepage

Oneside, ToC

Twoside, titlepage

Twoside, ToC

11
  • 2
    Hi and welcome, very good to post an example. A regular book is printed both sided, your document is specified oneside. Left pages are non-existent here.
    – Johannes_B
    Apr 14, 2015 at 11:07
  • 1
    In addition to Johannes' comment, under onside, only the odd layout is used, so even is ignored. You have to switch to twoside in order to get even and odd header design
    – daleif
    Apr 14, 2015 at 11:16
  • 1
    @daleif I got a chat ping and was distracted. I wanted to write more.
    – Johannes_B
    Apr 14, 2015 at 11:18
  • 1
    Also watch out for chapter style pages. Pages with new chapters have their own style and will not follow your standard style (don't be surprised that the page number will be centered).
    – remus
    Apr 14, 2015 at 11:21
  • Thanks! Changing it to twosided works! However, when doing so, the title page and ToC are messed up. With onesided, they are nice and collected, but with twosided, huge linebreaks are inserted in between. On the other hand the rest of the document looks great. Apr 14, 2015 at 12:21

1 Answer 1

3
  1. use twoside class option to enable left/right headers (in oneside only the odd version is used)
  2. Never use \pagebreak unless you know what you are doing. You are probably looking for \newpage
1
  • mange tak! شكرا
    – Johannes_B
    Dec 21, 2015 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.