5

I have a line in my novel which is not breaking in what I would think to be natural places. It appears to be due to my use of ldots:

``It was fine.'' she said, defensively. ``Just\ldots more and more\ldots   sporadic.'' She laughed self-conciously

The document class is memoir and I would expect the line to break naturally between \ldots and the following word but latex (pdflatex) appears reluctant to break at that point. It results in a very long overfull hbox (36pt too wide)

  • Can you provide a sample of the code set-up with this line included? I ran the line in a general case and the line breaks after ".. sporadic" and starts the new line with "she.." if the line starts a paragraph. – Leucippus Apr 15 '15 at 21:24
  • This has nothing to do with memoir – daleif Apr 16 '15 at 11:33
  • sorry to take so long to get back. @Leucippus, you are correct, the line breakes after the speech marks but with my set up this creates a very overfull hbox. – susie Apr 21 '15 at 11:34
7

There is no feasible line break point after \ldots

You can define your own version of dots with possible line break with

\newcommand{\bdots}{\textellipsis\linebreak[0]}

Example:

\documentclass{memoir}

\newcommand{\bdots}{\textellipsis\linebreak[0]}

\begin{document}

``It was fine.'' she said, defensively.
``Just\bdots more\bdots and\bdots more\bdots sporadic.'' She
laughed\bdots self-consciously
``It was fine.'' she said, defensively.
``Just\bdots more\bdots and\bdots more\bdots sporadic.'' She
laughed\bdots self-consciously
``It was fine.'' she said, defensively.
``Just\bdots more\bdots and\bdots more\bdots sporadic.'' She
laughed\bdots self-consciously
``It was fine.'' she said, defensively.
``Just\bdots more\bdots and\bdots more\bdots sporadic.'' She
laughed\bdots self-consciously
``It was fine.'' she said, defensively.

\end{document}

enter image description here

Disregard the two overfull boxes, the point was to show the line breaks after the dots.

3

I believe the \ldots command is eating the following space. You can replace your \ldots with \ldots{}.

sample\ldots{} text
  • I'll bear this in mind. I'm surprised that ldots does not already allow a line break immediately afterwards... must be one of those typesetting traditions! – susie Apr 21 '15 at 11:36
  • 1
    It's not a typesetting tradition. It's the way Tex and LaTeX handle spaces after a macro. It's not particular to the ldots command. Enclosing the \ldots in brackets would also work - like this... sample{\ldots} text – James Apr 21 '15 at 17:54
  • @susie I think actually this is the more normal setting, it differs from egreg's answer (and the code in your question) in that it has a word space after the dots in the case that the line does not break at that point (+1) – David Carlisle Apr 21 '15 at 20:34
  • more useful information! I've a lot to learn about LaTeX. – susie Apr 27 '15 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.