8

I just set up the MacTeX-2014 distribution on my MacBook working OS X Yosemite 10.10. As i try to build a document on which i already worked without a problem on said machine before clean installing on a new hard drive i get the following error message:

mktexpk: No such file or directory kpathsea: Appending font creation commands to missfont.log.

The missfont.log reads

mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9    
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9
mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 bbm9

I can't really make much of it and Google didn't help much either.

EDIT: I checked if the font is installed properly. This seems to be the case as kpsewhich bbm9.mf yields a correct path.

EDIT2: Documents not using any bbm fonts seem to work fine, documents using bbm fonts don't.

10
  • Try kpsewhich --format=mf bbm9.mf. If it prints nothing, bbm fonts are not installed. Commented Apr 19, 2015 at 9:37
  • Welcome to TeX SE! Or just kpsewhich bbm9.mf - if you get nothing, the font is either not installed or the database is not current. Can you compile a trivial document e.g. \documentclass{article}\begin{document}Hello!\end{document}? Just as a sanity check. I don't think this can possibly be the problem here, but you should also use TeX Live Utility to bring your distribution up to date since I don't think that MacTeX does a net installation.
    – cfr
    Commented Apr 19, 2015 at 12:54
  • 1
    Thanks for the warm welcome and thank you both for trying to help me here. Running kpsewhich prints the path as it should. According to it it is located at /usr/local/texlive/2014/texmf-dist/fonts/source/public/bbm/bbm9.mf. To me this does look proper so the issue must be something else.
    – foobar
    Commented Apr 19, 2015 at 13:31
  • What is odd as well is that i cannot access the section TeX Distribution of my system's preferences. I always get prompted the message that they couldn't be loaded giving no reason whatsoever.
    – foobar
    Commented Apr 19, 2015 at 13:44
  • 1
    How exactly did you 'clean install' and how exactly did you reinstall MacTeX?
    – cfr
    Commented Apr 19, 2015 at 20:17

2 Answers 2

13

After an odyssey of trying everything that came to my mind and talking to Robert Koch i finally found a solution to my problem. I am going to post the answer so that in the off chance of someone running into the same issue in the future there is no need for endless trial and error.

When i first encountered the problem i was using TeXstudio as an editor. Seemingly, TeX was able to find the meta font data in the tree but did somehow not manage to create proper pk files from it in ~/Library/texlive/2014/texmf-var/fonts/pk through TeXstudio. The directory ~/Library/texlive exists in order to allow TeX Live to automatically create files when missing the needed root permission.

Robert Koch gave me the idea to try and delete the texlive folder of the local library, typeset again and see what happens as the folder should be recreated without a problem when needed. Luckily - using TeXShop this time - TeX did exactly that and this time properly. Now that working pk files have been created i can even compile using TeXstudio. So in the end it seems to have been a front end problem after all. What i still did not figure out is why i encountered the issue in the first place and why i didn't the last time i used TeXstudio in what seems to have been the same set up at least softwarewise.

4
  • I seriously doubt that TeX even tries to write those files to /Library/ - and I certainly hope that it does no such thing. Even though running TeX with permission to write there would be idiotic, there is no call for software to add to the insanity. Also, TeX Shop does not, I think create ~/Library/texlive. TeX creates it and writes to it, as needed. TeX Shop has a separate folder somewhere which was (and, I'm assuming is) an entirely different matter. (It is bad enough, in my view, that Mac TeX forces you to manage the installation as root - there is no need to make things worse.)
    – cfr
    Commented Apr 21, 2015 at 1:26
  • You are obviously right. Not the front ends create ~/Library/texlive, TeX itself does. Do you have any idea why this wouldn't work properly when using TeXstudio but did work somehow when using TeXShop?
    – foobar
    Commented Apr 21, 2015 at 9:11
  • No. I have no idea. If you delete the directory and then use TeX Studio immediately, does it fail? It sounds very odd that it would find the files if they exist but be unable to create them. If it couldn't find them either, I'd say something must be mis-configured. But obviously, that is not the issue you're seeing so I'm not sure.
    – cfr
    Commented Apr 21, 2015 at 11:31
  • same thing happened here. Thanks for posting this, I would have been stuck for ages without it !
    – nicolas
    Commented Jan 22, 2020 at 12:19
2

Thanks for posting the question and for giving the solution. I also had the same problem, also with TeXstudio, and looking at the solution that you suggested, I tried something simpler and it worked. I simply compiled once with TeXShop (without deleting any directory) and then went back to TeXstudio, and the problem was solved. Hope this is useful to other people coming across the same problem.

3
  • 1
    But why? What is the difference between TeXShop and TeXStudio?
    – Mensch
    Commented Dec 16, 2015 at 10:45
  • Perhaps something with access rights or initial setup. TeXShop may create all the required directories when missing.
    – Christian
    Commented May 1, 2016 at 10:23
  • Thanks for the tip! Compiling via command line using sudo pdflatex instead of using TeXShop also worked for me. I just needed to remove the generated pdf file once afterwards since it apparently is read-only for normal user when created using sudo. After that, TeXStudio works just fine again.
    – SimonH
    Commented Sep 3, 2020 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .