1

I am using the beamer package and I have a title set at the top of the page, but I want to left align the title. So far I have this for the title portion:

\documentclass[final]{beamer}
\usepackage[scale=1.24]{beamerposter}
\usepackage{graphicx}       
\usepackage{tikz}

\newlength{\sepwid} \newlength{\onecolwid} \newlength{\twocolwid}
\setlength{\paperwidth}{48in} \setlength{\paperheight}{36in}
\setlength{\sepwid}{0.02\paperwidth} \setlength{\onecolwid}{0.22\paperwidth}
\setlength{\twocolwid}{0.464\paperwidth} \setlength{\topmargin}{-0.5in}
 \usetheme{confposter}
  \usepackage{array,booktabs,tabularx}
  \graphicspath{{figures/}}

  \title{\begin{flushleft} TITLE \end{flushleft}}
  \author{ \begin{flushleft}NAME\end{flushleft}  }
  \institute{ \begin{flushleft} INSTITUTE \end{flushleft} }

  \begin{document} %% \end{document}

This compiles fine but it displays the results as such and I cannot figure out how to fix it. Suggestions? enter image description here

  • 2
    Instead of the code snippet you've provided, how about a complete, minimal working example (MWE)? – Werner Apr 21 '15 at 2:04
  • 1
    Try with an empty beamer presentation, add only the minimal elements to show your issue so we know if you are using other packages, which themes, setting etc... – Bordaigorl Apr 21 '15 at 8:05
  • Thanks for the tip. I have changed the question to include a small working example as well as more detail on the problem it complies. – Nate Apr 21 '15 at 20:41
  • That's not an MWE. It will not produce the output you posted. Also, please provide a link for the theme as it is not in TeX Live. If I comment the theme out and add abc to the body, your code does NOT compile. You are surely ignoring errors galore to get any output at all! – cfr Apr 21 '15 at 23:45
  • You should tell beamerposter about the sizes rather than setting them manually e.g. \usepackage[scale=1.24, size=custom, width=122, height=93]{beamerposter}. You should never use explicit formatting markup in the arguments to commands such as \title{} (and this is the source of the enormous number of errors when you try to compile your code). The arguments should be just the plain text title, author etc. – cfr Apr 21 '15 at 23:58
2

I assume you are using the confposter theme from http://www.njohnston.ca/2009/08/latex-poster-template/. If this is the case, simply redefine the headline template to use \raggedright instead of the default \centering

Original definition

 \setbeamertemplate{headline}{
 \leavevmode
  \begin{columns}
   \begin{column}{\linewidth}
    \vskip1cm
    \centering
    \usebeamercolor{title in headline}{\color{jblue}\Huge{\textbf{\inserttitle}}\\[0.5ex]}
    \usebeamercolor{author in headline}{\color{fg}\Large{\insertauthor}\\[1ex]}
    \usebeamercolor{institute in headline}{\color{fg}\large{\insertinstitute}\\[1ex]}
    \vskip1cm
   \end{column}
   \vspace{1cm}
  \end{columns}
 \vspace{0.5in}
 \hspace{0.5in}\begin{beamercolorbox}[wd=47in,colsep=0.15cm]{cboxb}\end{beamercolorbox}
 \vspace{0.1in}
}

The complete example with the modification:

\documentclass[final]{beamer}
\usepackage[scale=1.24]{beamerposter}
\usetheme{confposter}

\setbeamertemplate{headline}{
 \leavevmode
  \begin{columns}
   \begin{column}{\linewidth}
    \vskip1cm
    \raggedright
    \usebeamercolor{title in headline}{\color{jblue}\Huge{\textbf{\inserttitle}}\\[0.5ex]}
    \usebeamercolor{author in headline}{\color{fg}\Large{\insertauthor}\\[1ex]}
    \usebeamercolor{institute in headline}{\color{fg}\large{\insertinstitute}\\[1ex]}
    \vskip1cm
   \end{column}
   \vspace{1cm}
  \end{columns}
 \vspace{0.5in}
 \hspace{0.5in}\begin{beamercolorbox}[wd=47in,colsep=0.15cm]{cboxb}\end{beamercolorbox}
 \vspace{0.1in}
}

\title{TITLE}
\author{NAME}
\institute{INSTITUTE}

\begin{document}
 test
\end{document}

The result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.