3

When using the siam bibliography style, if any two references contain the same author field, then the author field in the output is replaced with dashes (-----).

I can see by looking through other questions that this is also common behavior for several other bibliography styles, and there are examples of ways to fix this by editing (copies of) the offending .bst files, for example: -

Is it normal for BibTeX to replace similar author names with "------"?

dash instead of repeated author name

I have never before worked with .bst files, and still relatively new to latex. I haven't been able to locate the function within siam.bst that causes this default behavior.

I am committed to using the siam bibliography style for a current piece of work which contains a large number of citations. I haven't been able to replicate the workarounds designed for fixing this problem with other styles.

Can someone suggest a modification to siam.bst that would allow multiple entries in the bibliography with the same author?

  • Welcome to TeX SE! People would appreciate a minimal working example (MWE) which they can use for testing. You should consider switching to biblatex/biber if you can, though. Then these things are relatively easy. – cfr Apr 22 '15 at 0:08
1

To disable the replacing repeated author, organization, and editor names with long dashes when using the siam bibliography style, you could take the following steps:

  • Find the file siam.bst in your TeX distribution. Make a copy of this file and name the copy, say, siamnodash.bst. (Do not edit an original file from your TeX distribution.)

  • Open siamnodash.bst in your favorite text editor -- the editor you use to edit your tex files will do fine.

  • We'll be replacing three instances of a string that occupies an entire line.

    • First, find the function format.authors. (In my copy of the file, this function starts on line 89.) In this function, find the line that says

      { "\leavevmode\vrule height 2pt depth -1.6pt width 23pt" }
      

      Replace this line with

      { author format.names scapify }
      
    • Second, in the next function, named format.organization, replace the line

      { "\leavevmode\vrule height 2pt depth -1.6pt width 23pt" }
      

      with

      { organization scapify }
      
    • Third, in the next function, named format.editors, replace the line

      { "\leavevmode\vrule height 2pt depth -1.6pt width 23pt" }
      

      with

      { editor format.names scapify }
      
  • Save the file siamnodash.bst either in the directory where your main tex file is located or in a directory that's searched by BibTeX. If you choose the second option, be sure to update the filename database of your TeX distribution.

  • In the main tex file, change the instruction

    \bibliographystyle{siam}
    

    to

    \bibliographystyle{siamnodasH}
    
  • To fully propagate the changes, rerun LaTeX, BibTeX, and LaTeX twice more.

Happy BibTeXing!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.