2

When using the Latex-suite plugin in vim, typing ... expands to either \ldots or \cdots (see section 3.9 Smart Key Mappings of the latex-suite manual). I am using a lot the amsmath package that provides \dots, and I'd like to make ... expand to just \dots.

I tried putting

:call IMAP('...', '\dots','tex')

in $VIM/after/ftplugin/tex_macros.vim but it does nothing.

How can I make ... expand to \dots?

Moreover, is there any way to do the above only if the amsmath package is detected?

4

I'm not sure why what you tried didn't work (maybe you have to disable Smart Dots), disabling Smart Dots with let g:Tex_SmartKeyDot=0 in my vimrc and appending call IMAP('...', '\dots','tex') to ftplugin/tex_latexSuite.vim worked for me, but that's not what I would recommend. I would recommend using ::, which expands to \dots by default, as far as I know.

  • 1
    I had no idea about the :: shortcut, I'm going with that, thanks! – geo909 May 31 '15 at 15:14
  • I'm not even sure it's documented. I found it by accident. – Jake May 31 '15 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.