3

I'm currently writing a document on my "work-pc" meaning, that I do not have sudo rights on this machine.

It has some old version of hyperref installed, that is not compatible with pdfx and gives me the error: hyperref.sty: Package xkeyval error: 'pdfa' undefined in families Hyp.

I have downloaded a newer version of hyperref.sty from ctan and put it in a local directory. Then I have added said directory to the $TEXINPUTS variable, hoping that it would now use the newer hyperref version.

However it still uses the old one in /usr/share/texmf/tex/latex/hyperref/hyperref.sty which I don't have permissions to alter. How do I get it to use my new local version?

  • Thanks. I'll try that as well. :) I also remembered in the mean time that one can put the package in ~/texmf/tex as this is queried first, so this can be considered solved.... Wish I had remembered this 10seconds before I posted, not after :p – myrtille Apr 23 '15 at 14:50
  • 1
    Setting TEXINPUTS is the answer. presumably you did not add it correctly, but hard to say as you didn't show the value. – David Carlisle Apr 23 '15 at 14:51
  • 1
    In addition to what David says, have you got the correct layout for your local directory (<place>/tex/latex/hyperref/hyperref.sty) – Joseph Wright Apr 23 '15 at 14:54
  • @JosephWright Yes. Once I've moved it to ~/texmf/tex/latex/hyperref/hyperref.sty it worked. I only remembered to try this after posting here, unfortunately. – myrtille Apr 23 '15 at 14:57
  • @DavidCarlisle An answer? – Joseph Wright Jun 6 '15 at 21:13
4

If you set

TEXINPUTS=/your/local/directory:

Then Tex will look there first and then (because of the trailing : ) look in all the standard places.

You can set TEXINPUTS as an environment variable or as a value in a texmf.cnf file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.