2

This question already has an answer here:

I use TeXStudio when writing body text. One nice feature is it will autocomplete a lot of commands for you. The problem I'm having is that if I type \ch{ it 'fixes' this to \chapter{. Is there any way to turn this off, or add \ch to it above \chapter?

marked as duplicate by Canageek, Werner, Mensch, cmhughes, user13907 Oct 10 '15 at 19:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Go to options->configure Texstudip than completion buttun desable Auto replace latex commands – touhami Apr 23 '15 at 22:20
  • 1
    Check to make sure that \ch is in a .cwl that is being loaded by TeXstudio. See this answer and section 4.13 of the TeXstudio manual. – Jason Zentz Apr 24 '15 at 1:37
  • 2
    If your are referring to \ch from chemformula you might be interested in my answer here: tex.stackexchange.com/a/263504 – LaRiFaRi Aug 27 '15 at 22:43
  • @LaRiFaRi Finally got around to setting this up, can you make it an answer? – Canageek Oct 7 '15 at 19:13
  • @Canageek this would be a duplicate then. Just accept Mr. Zentz answer as the first sentence was exactly what helped you. Or you close your post ad a dupe with reference to the post I linked. Thanks. – LaRiFaRi Oct 8 '15 at 8:29
3

Check to make sure that \ch is in a .cwl that is being loaded by TeXstudio. See this answer to TeXStudio doesn't recognize some commands and section 4.13 of the TeXstudio manual.

  • I finally set down and double checked this, and yes, the entire chemmacros family is loaded in TeXStudio. – Canageek Jun 10 '15 at 18:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.