1

When I run

pandoc markdown.md --template=my-template.tex --latex-engine=lualatex -o test.pdf

I get the following error message:

pandoc: lualatex not found. lualatex is needed for pdf output.

I was running this command a few weeks ago but it not longer works.

  • 1
    What does which lualatex say? – Sean Allred Apr 24 '15 at 17:46
  • it says not found. should I just reinstall mactex again – pdoak Apr 24 '15 at 17:48
  • 1
    I'm not sure how you could've borked it unless you've been messing with your PATH (which you should really only do when you already know how to fix these sorts of problems) -- what does which tex say? – Sean Allred Apr 24 '15 at 18:04
  • that says tex not found also. My $PATH looks okay:/Users/xxx/.composer/vendor/bin:/Documents/Ruby:/Users/xxx/.rbenv/shims:/usr/local/bin:/usr/local/sbin:/Users/xxx/.rbenv/bin:/Users/xxx/rbenv/shims:/usr/bin:/bin:/usr/sbin:/sbin:/Users/xxx/.yadr/bin:/Users/xxx/.yadr/bin/yadr – pdoak Apr 24 '15 at 18:25
3

If you're using an older installation of MacTeX, make sure /usr/texbin is included in your PATH environment variable. Otherwise, use /Library/TeX/bin.

  • I have the same problem. Could you please tell me where to put /usr/texbin ? PS: I am using this template latextemplates.com/template/wilson-resume-cv – Günal Dec 28 '15 at 11:35
  • The document you are compiling is of no consequence. What do you mean 'where do I put it'? See also my recent edit. – Sean Allred Dec 28 '15 at 15:27
  • @SeanAllred The change in path is independent of El Capitan, it was just precipitated by changes in El Capitan. With MacTeX 2015 /Library/TeX/bin will work on any version of the OS. – Alan Munn Dec 28 '15 at 15:30
  • @AlanMunn Good to know, thanks – and edited :-) I've still not updated – I'm afraid (perhaps irrationally) that too many things will break. – Sean Allred Dec 28 '15 at 15:32
  • @Günal Sorry, I forgot to ping you. See my comment above. – Sean Allred Dec 28 '15 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.