11

I think it's probably unnecessary to think of changing the length of skips between paragraphs in the sense that the standard spacing of one skip defined by the parskip package is always fine. But what about if I wanted two skips instead of one, or even worse if I wanted to change the length of the skip. I was thinking about modifying the value of \parskip, which apparently solves the problem. Truth is it also modifies my enumerate environments and I don't want that. Actually that makes me think that it may probably do the same thing with some other environments. How can I solve this?

1
  • 1
    If you load the enumitem package, you can control its spacing parameters explicitly. Should be able to make them independent of your modified \parskip length. Apr 27 '15 at 0:51
8

Apart from the "dont' do this" warning that you will most certainly receive, the memoir class allows you to change the regular \parskip value without messing up other things, by providing an \abnormalparskip macro:

\documentclass{memoir}
\usepackage{blindtext}
\abnormalparskip{2\baselineskip}
\begin{document}
\blinddocument
\end{document}

output of code

5

The package parskip does three things: (1) sets a zero \parindent, (2) sets a non-zero \parskip, and (3) adjusts the skips between list items to \parindent.

So, simply carry out (1) and (2), setting the \parskip length to stretchable glue, avoiding the need for the parskip package:

MWE

\documentclass{article}
%\usepackage{parskip}
\setlength{\parindent}{0pt}
\setlength{\parskip}{4\bigskipamount plus \smallskipamount minus \smallskipamount}
\begin{document}
Text\par
Text\par
Text\par
Text\par
\begin{enumerate}
\item One 
\item Two
\item Three
\item Four
\end{enumerate}
Text\par
Text\par
Text\par
Text\par
\end{document}
3
  • somehow, neither the parskip package nor manually setting the parskip works for setting a custom skip in my case...
    – xeruf
    Apr 29 at 19:08
  • @Xerus "Your case" mean in another document? Then there is something in conflict with that setting. Otherwise, you are doing something wrong to reproduce the example. Anyway, only you can check what could be.
    – Fran
    Apr 29 at 19:38
  • indeed, I found it out after experimenting for a while, I set an org-mode flag incorrectly...
    – xeruf
    Apr 29 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.