0

I tried to compile the auctex from Emacs MELPA. The version is: 11.88.4

When I first open a .tex file, compile AUCTEX, and change to "TeX-latex-mode", Emacs will work properly, the menu bar also change to latex state.

However, when I close Emacs, restart Emacs again and open a .tex file, Emacs will give:

Debugger entered--Lisp error: (error "Autoloading failed to define function TeX-latex-mode")

And auctex will not work...

It seems the problem is in autoloading certain state when initialize the auctex for a tex file.

Any help?

  • Try just LaTeX-mode… AUCTeX should have 'advised' it to run its functionality. – Sean Allred Apr 27 '15 at 2:38
  • I do not quite understand. I didn't specific a "TeX-latex-mode". It is because I was in Tex-mode before I installed auctex. If I open new file after the auctex installed, emacs will give the error. – X.Arthur Apr 27 '15 at 2:53
  • I assume you tried restarting Emacs? – Sean Allred Apr 27 '15 at 2:56
  • Yes. If not restarting, changing to Latex-mode will work. If restarting, it give the error... – X.Arthur Apr 27 '15 at 3:03
  • Without more information about your configuration, it will be impossible to help. If it's of any use to you, feel free to use my configuration. – Sean Allred Apr 27 '15 at 3:05
1

Problem Solved! My mistake.

I modularised my init.el and separated the LaTeX settings to latex.el, which conflict with the latex.el in auctex.

I renamed the file to latex_settings and everyting works fine. (A small warning that no docstring for 'tex-start-shell', but that's fine.)

  • Yep, that'd be a problem :) I'm glad everything worked out. – Sean Allred Apr 27 '15 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.