5

I receive the following errors:

! Package minted Error: You must invoke LaTeX with the -shell-escape flag.
! Package minted Error: You must have `pygmentize' installed to use this packag

in TexMaker Settings i wrote:

LaTeX : "/usr/texbin/latex" -interaction=nonstopmode %.tex -shell-escape

PdfLaTex: "/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex -shell-escape

But the error still doesn't vanish ...

3
  • 1
    Move %1.tex to the end. Also, did you install pygmentize?
    – Sigur
    Apr 27, 2015 at 18:16
  • @Sigur Do you want to write an answer? Jun 6, 2015 at 21:56
  • @TorbjørnT., done!
    – Sigur
    Jun 7, 2015 at 5:01

2 Answers 2

7

The error says ! Package minted Error: You must invoke LaTeX with the -shell-escape flag.

So you have to use the flag -shell-escape when compiling, that is, use it before the name of the file.

To do this, move %.tex to the end.

-interaction=nonstopmode -shell-escape %.tex
0

I will post this for future users facing a similiar issue.

Check your antivirus program. In my case "Norton" blocked the process "pygmentize.exe".

I got followed error:

Package minted Error: Cannot find Pygments style default. \end{minted}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .