2

I'm using the default article documentclass for a document that is just supposed to hold the accompanying figures for a paper. This is what I'm doing:

\documentclass{article}
\usepackage{graphicx}
\graphicspath{ {path} }
\geometry

\begin{document}\vspace{-10ex}
\title{My title}
\author{Author 1        \and
        Author 2 \and
        Author 3 }
\maketitle  
\\
\\

\center

\section*{Accompanying Figures}

\begin{figure}
  \includegraphics[width=7cm]{twoapproaches.pdf}
\caption{Two approaches to mutli-class vehicle classification}
\label{fig:1}      
\end{figure}\\  
% Few more figures
\end{document}

On the first page I have to put a rather long diagram, but it always shows up on the second page. I thought maybe it just doesn't fit. I reduced the image size but it only comes on the first page if I make it really small. I have an entirely empty first page! How can I fix this? How can I edit the margins/font size of the default article document class?

  • Kick out the double backslashes, use vspace instead. The command is called \centering, don't use the figure environment. If you need a caption, use captionof{figure}{Your caption} form package capt-of. A less forcing approach would be adding placement option b. But i fear, that there is not enough available space on the page. – Johannes_B Apr 30 '15 at 13:13
  • I doubt that the figures are allowed on the same page as title. Use captionof as suggested by Johannes. – user11232 Apr 30 '15 at 13:16
  • 1
    \geometry isn't defined here \center shouldn't be used as a command and most \\ need to be removed (especially the one after \end{figure} You get multiple errros from this as posted – David Carlisle Apr 30 '15 at 13:21
  • 1
    I bet it's the \maketitle. It does odd things. – Mark Dec 27 '15 at 2:36
  • 2
    @Mark: Boromir of LOTR would say: In \maketitle, there's evil, that does not sleep ;-) – user31729 Jun 23 '16 at 22:00
2

One suggestion is to use float package and H position, forcing the figure to stay in its position in the text. Just add \usepackage{float} to your preamble and start your figure as \begin{figure}[H].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.