1

I am compiling LaTeX files with Texmaker on Ubuntu 14.04 system.

When I run pdflatex and then view the .pdf file (internal), it does not show me the exact place where I am editing on Texmaker i.e. the generated pdf file does not show me the position of the cursor.

This question was already asked before (Texmaker generated pdf file not showing the position of cursor) but the answers don't work in my case.

Probably the reason is that I am using a multi-file latex (each chapter in a separate tex) and I compile a template.tex file which has the \include command to "call" the separate chapters*.tex files.

  • Make the main file (the one with preamble) to be the Master Document. – Sigur May 2 '15 at 9:34
  • @ Sigur: I have already tried that, but it doesn't change anything. – Thomas May 2 '15 at 9:43
  • @LCF, to make sure: are you using the synctex option? – Sigur May 2 '15 at 9:54
1

Even though I first did not notice, the comment by Sigur appeared to be the correct answer - thanks for that!

When making the main file to be the Master Document, one can compile each chapter separately without the need to compile the main file.

Then, when running pdflatex and viewing the internal .pdf file, it shows me the exact place where I am editing on Texmaker.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.