2

when using the texpath command in Asymptote, I only get an empty path array. I'm using a miktex installation on a Windows 8 machine, ghostscript is installed. (I also have a TeX Live installation on a Linux machine where this works fine).

edit: Here's a simple example, where this problem shows up:

draw(texpath("Hello, World!"));
label(string(texpath("Hello, World!").length), (0,0));

The resulting pdf-file (and also the resulting eps-file) shows a single 0.

edit 2: I'm using ghostscript version 9.16 (32bit, but the same problem occurs with the 64-bit version).

  • Could you give us an example of a problematic program using this module? – Franck Pastor May 3 '15 at 15:27
  • 1
    Please specify ghostscript version. I think texpath uses ghostscript (or pstricks) so the odd behavior is related to the bug (asy uses a deprecated gs driver). The bug is solved in the svn version (see asy svn page). There are also another messages here about it. – O.G. May 3 '15 at 19:30
  • See tex.stackexchange.com/questions/239370/… and the link. So you have to wait the new compiled version or downgrade ghostscript (under windows). – O.G. May 4 '15 at 11:45
  • @O.G.: Downgrading ghostscript worked for me---thanks a lot! Please turn your comment into an answer, so that I can accept it. – tobias May 4 '15 at 17:19
2

Hy

A new version of Asymptote, v2.33, was released today. From the update

A work around was implemented for the missing epswrite driver in ghostscript-9.15.

So it seems that you can use Ghostscript >=9.15 and Asymptote 2.33

Old message : See Building with asymptote: file-2.tex not found, null surface and also Labels in 3D mode don't work in Asymptote. So you have to wait the new compiled version or downgrade ghostscript (under windows).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.