1

I most likely caused this problem for myself, but I would welcome any suggestions to help dig me out of this hole.

First of all, I tried to install texlive 2011 and got the error message that my local version was different from the version in the repository (should have read the instructions first...). In any case, my easy fix was to just wipe out my entire C:\texlive folder. Problem solved, right? Not so much.

I then read that I should have used the Add/Remove programs option in Windows to get rid of TeX Live, which I then did. I also removed any reference to C:\texlive from the PATH. However, I'm still getting

the local installation
and the repository being accessed are not compatible:
      local: 2010
 repository: 2011
Perhaps you need to use a different CTAN mirror?

Where else do I need to go so that my computer doesn't still think TL 2010 is still installed?

5
  • 1
    Try to redownload the installer. Maybe you still have the one for TL 2010.
    – Caramdir
    Commented Jul 28, 2011 at 4:35
  • Caramdir, I'm fairly certain it was for TL 2011 since the folder name was "install-tl-20110510". However, I re-downloaded the install-tl.zip from the texlive website and noticed that it was already a different version from what I had downloaded earlier in the day (install-tl-20110727). I ran "install-tl.bat" and it worked first time. This issue can be disregarded.
    – Michael
    Commented Jul 28, 2011 at 4:50
  • 2
    TL 2011 was released a few days ago, so I guess install-tl-20110510 was still for TL 2010, despite the name. The first time you probably hit a mirror that hadn't yet updated to TL2011.
    – Caramdir
    Commented Jul 28, 2011 at 4:55
  • (I wrote an answer, but I'm not against closing this as “too localized”, since the mirrors should all have TL 2011 sometime soon.)
    – Caramdir
    Commented Jul 28, 2011 at 5:00
  • IMO this is not too localized since it may happen next year, and your answer addresses all cases of outdated mirrors.
    – mpg
    Commented Jul 28, 2011 at 10:56

3 Answers 3

8

I seems that you got an installation file from a CTAN mirror that hadn't yet updated to TL 2011. Redownload it and try to be more lucky the next time (most mirrors should have updated by now).

Conversely, when you get the error message

the local installation
and the repository being accessed are not compatible:
      local: 2011
 repository: 2010

then just restart the installation process until you hit an updated mirror.

3

start the tlmgr as a gui: tlmgr --gui. Then choose another mirror from the tlmgr topic.

1

The message

the local installation
and the repository being accessed are not compatible:
      local: 2010
 repository: 2011
Perhaps you need to use a different CTAN mirror?

means you are trying to install TexLive 2010 but the latest version is 2011. This message appears even if you don't have any TexLive version installed.

2
  • Your answer adds nothing new to the already existing answers. Commented Jan 7, 2022 at 9:03
  • Indeed: that was driving me crazy. I couldn't figure out why it told me that I had TL 2021 locally, when I got rid of everything related to TL in my computer. I had to download a newer installer and it took me months to figure it out. I wish I had seen this answer before.
    – Andyc
    Commented May 27, 2022 at 1:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .