I'm using chemstyle to create a list of chemical schemes (within classicthesis), but it numbers the list differently from my lists of Figures and Tables. Is there a way to change, for example, 1.1 into Scheme 1.1 and then edit the spacing so it matches everything else?


\documentclass[twoside,openright,titlepage,numbers=noenddot,headinclude,footinclude=true,cleardoublepage=empty,abstractoff,BCOR=5mm,paper=a4,fontsize=10pt, american,english]{scrreprt}

    \setchemnum{format= \normalfont

\newcounter{dummy} % necessary for correct hyperlinks (to index, bib, etc.)


    \let\cleardoublepage\relax %removes gaps between lists





\let\origaddvspace\addvspace%extra lines to stop breaking between chapter groups
\renewcommand{\addvspace}[1]{}%extra lines to stop breaking between chapter groups
\renewcommand{\addvspace}[1]{\origaddvspace{#1}}%extra lines to stop breaking between chapter groups




  {figure here}

  {table here}

  {scheme here}


Screenshot of Lists Update - This issue seems to arise in how chemstyle implements the tocloft \newlistentry command:


It calls the argument name as {scheme} and this creates many of the usual commands, so for example \thescheme works fine. However options that should act on this, such as \cftschemepresnum remain undefined. Is there a reason for this behaviour?

  • Sorry - I just realised this - will edit to amend. – Will Peveler May 6 '15 at 9:25

Whilst chemscheme does what it does well, it's not really that easy to integrate it into a complex set up like classicthesis. I'd probably simply define the scheme environment by hand at the appropriate point

\newlistof[chapter]{scheme}{los}{List of Schemes}
% Based on set up in classicthesis



  figure here

  table here

  scheme here


Here I've copied the set up from classicthesis for tables and altered it for schemes.

  • Many thanks! That gets things working, but is there a way to call chemstyle and retain it's other functionality without chemscheme? This way I would avoid the compile error of having list of schemes defined twice? – Will Peveler May 14 '15 at 9:01

Based on the answer here I added the following to the code before \begin{document}:


This causes an error on compile, that scheme has been previously defined, but if ignored, the document will compile with the changes to the table of schemes. It still seems like chemscheme isn't passing all the information to tocloft, but as a quick and dirty fix, this is the best I have!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.