0

I am using TexShop 3.5.1, Bibdesk 1.6.3, on Mac OS 10.10.3. I am trying to compile a bibliography on a latex document that previously successfully compiled. Since then I have updated from the previous Mac OS 10.9 to Yosemite (10.10.3).

Now when I compile using the Applescript Bibliography option on TexShop, the console nicely scrolls by as usual and a pdf is generated (as expected) with citations indicated by question marks. But at the next step, when it is time to generate the .bbl file, the console goes blank and no script rolls by. I then have to "abort" the console (and usually TexShop freezes and I have to "force quit" the application).

Same thing happens if I do the latex and biblatex steps separately. Tried removing aux files, no help.

Other complication: I was previously using biblatex before Yosemite upgrade, but present file uses bibtex and have changed over to bibtex by altering preferences in TexShop.


Simplest MWE I could think of:

\documentclass[11pt, oneside]{article}      % use "amsart" instead of "article" for AMSLaTeX format
\usepackage{geometry}                       % See geometry.pdf to learn the layout options. There are lots.
\geometry{letterpaper}                          % ... or a4paper or a5paper or ... 
%\geometry{landscape}                       % Activate for for rotated page geometry
%\usepackage[parfill]{parskip}          % Activate to begin paragraphs with an empty line rather than an indent
\usepackage{graphicx}               % Use pdf, png, jpg, or eps§ with pdflatex; use eps in DVI mode
                                % TeX will automatically convert eps --> pdf in pdflatex        
\usepackage{amssymb}

\title{Brief Article}
\author{The Author}
%\date{}                            % Activate to display a given date or no date

\bibliographystyle{journal}


\begin{document}
\maketitle
%\section{}
%\subsection{}

Please work \cite{Smith:2008aa,Jones:2002aa}. I beg you \cite{Smith:2007aa}.

\bibliography{learned}

\end{document}  
  • Welcome to TeX.SE. Which version of MacTeX do you use? Where might the bibliography style journal be found? – Mico May 9 '15 at 8:06
  • 4
    Hi and welcome, have you tried running BibTeX in terminal to rule out any editor issues? – Johannes_B May 9 '15 at 8:09
  • Thanks Mico and Johannes! Mico: The version of MacTex is TexLive-2014. I have run the "updates" and apparently it is the latest. The bibliography style journal is in the same folder as the .tex file. Sorry, Johannes, I am too helpless to know how to run BibTex in terminal. I will try and look it up. – Bob May 9 '15 at 8:25
  • Hi Johannes: As you suggested I ran BibTex in terminal and successfully generated a .bbl file! There were three complaints in the terminal of the nature "You can't pop an empty literal stack for entry Greenfield:2013aa while executing---line 1233 of file journal.bst" but I think this is idiosyncratic for those citation entries. I tried using TexShop having built the .bbl to insert the citations, but no luck. – Bob May 9 '15 at 8:34
  • Hi Johannes again, I copied and pasted .bbl file in references section (commenting out \bibliography{learned}) and the bibliography then compiled! So, not quite sure what is going wrong, presumably connected with the "editor issues" you mentioned? – Bob May 9 '15 at 8:41
2

First off just want to thank you all for your help -- greatly appreciated!! I reached out to Herb Schulz who is a prominent "aider and abettor" on MacTex at tug.org. He thought it likely that the Applescript Bibliography macro had been broken by the upgrade to Yosemite. He suggested that I use the pdflatexmk engine in TeXShop to take care of all the compiling steps automatically, which I am now doing.

I can do no better than to quote Herb's own words as follows:

"First, in the Source window toolbar there should be a popup menu listing all the available engines. In all recent versions of TeXShop you should see a pdflatexmk engine. If you are compiling using pdflatex you're set. If you don't see the pdflatexmk engine on that list (that would happen if you have been using TeXShop for a long time) or you need the latexmk engine you'll have to move those engines into place. First quit TeXShop. Then move all the files with extension .engine from ~/Library/TeXShop/Engines/Inactive/Latexmk two levels up, to ~/Library/TeXShop/Engines. (Note: ~/Library is the Library folder in your HOME folder. Under OS X 10.7 and later it is invisible by default. To open that folder Click on the Go Menu in Finder and press the Option key and a new menu item for Library will appear; click on that item.) Open TeXShop and see that the additional engines (including the pdflatexmk and latexmk) are now shown in the popup menu in the Source window toolbar.

Once the pdflatexmk/latexmk engine is shown you activate it for a source file by placing the line

% !TEX TS-program = pdflatexmk

at the top of the file (or replace pdflatexmk above with latexmk if you compile with latex rather than pdflatex). From then on simply clicking on Typeset->Typeset (Cmd-T) should take you through all the steps necessary to compile your document automatically."

A relevant web page is

all-in-one-engine for TeXShop

This strategy will also work with Biblatex/biber and has the advantage that the "BibTex Engine" settings in the "Engine" tab of the TexShop Preferences do not have to be changed from bibtex to biber -- it all happens automatically.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.