2

How can I make the Reference visible in the table of contents without numbering it? I use the document class article. So far I have been using \usepackage[nottoc,numbib]{tocbibind}, but this numbers the Reference like a section.

I have also tried \addcontentsline{toc}{section}{References}, but this doesn't seem to work in a article.

Thanks in advance!

5
  • 1
    Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – user31729
    May 9 '15 at 13:44
  • Do you mean the bibliography as an entry in the toc? The Reference is a little bit misleading
    – user31729
    May 9 '15 at 13:45
  • 1
    Try loading tocbibind without the numbib option, that is \usepackage[nottoc]{tocbibind} May 9 '15 at 15:46
  • I mean bibliography. I'm sorry, reference is indeed a bit misleading.
    – Gregory
    May 10 '15 at 9:24
  • Loading the tocbibind without the numbib worked! Seems actually very obvious, but I never payed any attention to numbib. Thanks for the help!
    – Gregory
    May 10 '15 at 9:26
3

Brute force method with \addcontentsline

\documentclass{article}

\usepackage[backend=biber]{biblatex}
\addbibresource{biblio.bib}

\usepackage{blindtext}
\begin{document}
\tableofcontents
\section{First}
\blindtext[14]
\nocite{Lam94}
\clearpage
\addcontentsline{toc}{section}{\refname}
\printbibliography
\end{document}

Better way with heading=bibintoc method from biblatex (it's easier)

\documentclass{article}

\usepackage[backend=biber]{biblatex}
\addbibresource{biblio.bib}

\usepackage{blindtext}
\begin{document}
\tableofcontents
\section{First}
\blindtext[14]
\nocite{Lam94}
\printbibliography[heading=bibintoc]
\end{document}

enter image description here

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.