1

Something weird started to happen and I don't know how to change it back. I'm using LyX.

Whenever I try to undo something using Ctrl + Z I get this: ; when I try Ctrl + R I get this: ; the Enter, Backspace and delete are also giving me symbols; any combination of Ctrl + "key" gives me a different symbol, many of which are Hebrew letters.

  • 2
    Hi and welcome, please check if you accidentally switched to another keyboard layout or if any other key is stuck. – Johannes_B May 9 '15 at 14:15
  • Thanks but it's not. And nothing seems to be stuck :\ – E.T. May 9 '15 at 14:21
  • 1
    Check under Tools > Preferences > Editing > Shortcuts and make sure you're using cua as your bind file. – Werner May 9 '15 at 16:22
  • I wonder if this is the same bug as tex.stackexchange.com/questions/243999/… – scottkosty May 9 '15 at 18:11
  • @Werner Thanks! that seems to have solved the problem :) – E.T. May 10 '15 at 15:55
3

LyX allows the user to tailor the input-experience through what is called "key bindings". Informally they are sometimes referred to as (key) shortcuts. An excerpt from Customization.lyx, section 3.3. Bindings:

Bindings are used to, well, bind a function to a key. Several prepackaged binding files are available: a CUA set of bindings (familiar as the typical set of PC and CDE set of keyboard shortcuts), an Emacs set of bindings, for those of us who follow the One True Way and refuse to lower our standards, I'm kidding here, of course! as well as specialty bindings (broadway and hollywood) and other languages (French, German, etc.).

In your case, this may have switched to something other than the default/basic cua.

To change the key bindings, follow Tools > Preferences... > Editing > Shortcuts and enter cua, or Browse for another.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.