1

Using lmodern package and \scshape in beamer:

\documentclass{beamer}
\usepackage{lmodern}

\begin{document}
\frame{\scshape Normal size text}
\end{document}

gives:

LaTeX Font Warning: Font shape `OT1/lmss/m/sc' in size <10.95> not available
(Font)              Font shape `OT1/lmr/m/sc' tried instead on input line 5.

What is the recommended way to deal with this warning? Silencing it would be ok.

  • it's telling you that you don't have sans serif small caps, what is recommended depends mostly on what you want. leave as is, pick a different font that has sans caps and small caps, change the document not to select that, ... – David Carlisle May 11 '15 at 18:41
  • I don't have the option to change the font shape, it is generated by a package. Tried to silence it but it didn't work. It's annoying to have many warnings of this sort. – Desik May 11 '15 at 19:00
  • If your goal is to silence the warnings, try \usepackage{silence} \WarningsOff*. – Sverre May 11 '15 at 19:39
  • Yes, silencing this way works. How could I silence just this sort of warnings? – Desik May 11 '15 at 19:52
  • You do have the option to change the font shape. If you delete \scshape then it will not try to use that font shape. – cfr May 11 '15 at 20:40
2

I managed to filter the warnings, with either

\usepackage{silence}
\WarningFilter{latexfont}{Font shape}

or, if silence package have to be loaded in safe mode:

\usepackage[safe]{silence}
\WarningFilter*{latexfont}{Font}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.