1

I've been trying many different ways to sort my Bibliography as it appears in the text. But unfortunately it's always sorted the alphabetical way.

I'm using the following packages in my master file (I'm using a template and I don't know what this all stands for, since I'm using latex for the first time):

\documentclass[11pt,twoside,a4paper,DIV11,pointlessnumbers]{scrartcl}
\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc}
\usepackage{color}
\usepackage[ngerman]{babel}                 
\usepackage[left=2.5 cm,right=2.5 cm,top=2.5 cm,bottom=1.7cm,bindingoffset=0.6cm]{geometry}
\usepackage[ngerman]{datetime}
\addtokomafont{caption}{\small}
\newdateformat{digitsdate}{\twodigit{\THEDAY}.\twodigit{\THEMONTH}.\THEYEAR}
\pagestyle{fancy}
\setlength{\headwidth}{\textwidth}
\renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}
\fancyhead{}
\rhead[\nouppercase{\rightmark}]{\thepage}
\lhead[\thepage]{\nouppercase{\rightmark}}
\fancyfoot{}
\usepackage{subfigure}                         
\usepackage[thickspace,thinqspace]{SIunits} 
\usepackage{helvet}  
\renewcommand{\familydefault}{\sfdefault}

And with this code I'm trying to add my .bib file (arbeit.bib) in my masterfile:

\newpage
\addtocontents{toc}{\vspace{.5\baselineskip}}
\addcontentsline{toc}{section}{\protect\numberline{}{Literaturverzeichnis}}
\bibliographystyle{unsrt}
\bibliography{arbeit}

When run the arbeit.bib file I get following errors:

Process started This is BibTeX, Version 0.99d (MiKTeX 2.9) The top-level auxiliary file: arbeit.aux The style file: abbrv.bst A level-1 auxiliary file: Zusammenfassung.aux A level-1 auxiliary file: inhalt.aux Illegal, another \bibstyle command---line 13 of file arbeit.aux : \bibstyle : {unsrt} I'm skipping whatever remains of this command A level-1 auxiliary file: Anhang.aux Database file #1: arbeit.bib I was expecting a ,' or a}'---line 59 of file arbeit.bib : : @misc{rainforest_ind, (Error may have been on previous line) I'm skipping whatever remains of this entry (There were 2 error messages) Process exited normally

I have been trying many different styles which all should sort by the appearance... but without success. I hope someone might help me with my problem.

migrated from stackoverflow.com May 13 '15 at 0:45

This question came from our site for professional and enthusiast programmers.

  • Hi, it seems you are a german speaker, please have a look at LaTeX-Vorlagen. Many packages in your template are obsolete, the obsolete clas options will run into compatibility mode, loosing lots of features. I would not recommend using this template. – Johannes_B May 22 '15 at 11:31
  • 1
    It seems you are using bibliographystyle two times, which confuses BibTeX. You have shown only snippets, so i cannot be sure, though. – Johannes_B May 22 '15 at 11:32
1

Did you try biblatex? It has the option for sorting: none Do not sort at all. All entries are processed in citation order

I suppose that that is what you want.

[added:]

To your style file or preamble, add:

\usepackage[citestyle=authoryear,bibstyle=authoryear,backend=biber]{biblatex}
\ExecuteBibliographyOptions{sorting=none}

Of course, there are many more options.

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. It'd be best to expand this to a brief but complete example of biblatex used in this way. – Paul Gessler May 22 '15 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy