22

I am trying to understand how to change the order in which citations appear when I use multiple entries. Unfortunately the BibLatex documentation is not really helpful, its so complicated.

Lets say I have this citation \citep{Smith2003,Black2011,Church2012} I want them to appear (Smith, 2003; Black, 2011; Church, 2012), but I am instead getting (Black, 2011; Church, 2012; Smith, 2003).

I presume it is sorting them alphabetically by default. How do I change this? I don't want to change the order in which they appear in the Bibliography, they're alphabetical and I want them that way. Its the in-citation ordering I want to change.

Is there a way to tell it not to sort them and put them in the order I put them when doing citations with multiple references?

8
  • 4
    See the documentation of the option sortcites. Commented May 14, 2015 at 16:50
  • 1
    Cheers, I was looking at citeorder and couldn't understand anything! Is there any option to make them sort by year instead of no sorting or alphabetical?
    – jbx
    Commented May 14, 2015 at 16:56
  • 1
    By default it uses either the sorting of the bibliography or no sorting. Other sortings are imho possible but rather tricky to implement. Commented May 14, 2015 at 17:12
  • Thanks. Well this is enough. I can put the cite ordering in the way I like anyway in this way, not that 2 or 3 citations need to be automated.
    – jbx
    Commented May 14, 2015 at 18:03
  • 1
    biblatex allows for a different sort order in citations and the bibliography, until version 2.9a that is. As soon as I have the new version up and running, I will investigate about version 3.0.
    – moewe
    Commented May 15, 2015 at 17:28

3 Answers 3

8

Please see for Biblatex: how to automatically sort citation by year (sortcites=ynt) when references are sorted by name (sorting=nyt) a more thorough discussion and an alternative approach with a more modern version of biblatex.

You can specify the sorting of the bibliography separately from the sorting of the citations (enabled via sortcites).

In the pre-biblatex 3.0 days you would just have used an optional argument to \printbibliography, but now (i.e. starting from version 3.0) you have to use an optional argument to a new "refcontext" environment and wrap the bibliography in said environment.

\documentclass{article}
\usepackage[backend=biber,style=authoryear,sorting=ynt,sortcites]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}
\cite{worman,geer,baez/article,wilde,knuth:ct:a,knuth:ct:b}

\begin{refcontext}[sorting=nyt]
\printbibliography
\end{refcontext}
\end{document}

Wilde 1899; Knuth 1984; Geer 1985; Knuth 1986; Worman 2002; Baez and Lauda 2004

3
  • Thanks for the answer, but this gives me an "empty bibliography" warning, and no bibliography. If I comment out the refcontext environment it works, albeit with the wrong sorting in the bibliography. In case it matters, all of the citations (but not the \addbibresource commands) are in \include files. (BibLaTeX 3.1)
    – Flyto
    Commented May 5, 2016 at 16:30
  • @SimonW Can you update to version 3.3 and try again? If that doesn't help, please ask a new question with an MWE that demonstrates the problem.
    – moewe
    Commented May 5, 2016 at 16:36
  • 1
    Biblatex 3.6/Biber 2.5 appears to break this. Presumably a bug? See tex.stackexchange.com/questions/332978/…
    – cfr
    Commented Oct 7, 2016 at 0:54
2

If you just want your multi-citations to appear in the order that you cite them whilst keeping your bibliography sorted, you need to specify sortcites=false when you load biblatex.

For example:

\usepackage[style=authoryear,sorting=nyt,sortcites=false]{biblatex}

I owe this to @UlrikeFischer's comment but because comments are easily missed, I thought I would add it as an answer.

-1

This is very simple, you just need to specify in the preamble:

\usepackage[comma]{natbib}

See more in: https://es.sharelatex.com/learn/Bibliography_management_with_natbib

1
  • 2
    What does this have to do with the order of authors in a citation?
    – jbx
    Commented Mar 2, 2017 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .