1

I am working on a customized class file for a journal project, and the output PDF is not what it should be. Here is a link to the customized class file I have been modifying: https://www.dropbox.com/s/uxauz0kw1n4m8y7/actaspartae.cls?dl=0

And an MWE:

\documentclass{actaspartae}
\usepackage{hyperref}
\begin{document}

\subjectarea{Science}

\title[Short Title For this Article]{This is a Long Title For This Sample  Article}

\author{Jane Student}              
\affil{Department of Science} 

\maketitle

\begin{abstract}
This is a short statement which describes the research that I did.
\end{abstract}

\end{document}

When I compile any text using this class file using TeXShop, TeXWorks, or Latexian on MacTeX 2014 (updated yesterday to the newest packages), a mysterious hrule or two appears across the text on the last or next to last page. The line appears no matter how short or long the text. There is nothing in the document class that should put an \hrule or a \rule except at the headers, footers and title. Before the update yesterday, I did not see this behavior.

If I compile the exact same text and class files using ShareLatex.com, it compiles correctly with no mysterious lines. I have not tested this with any LaTeX installation on Windows or Linux.

I do not believe that it is the class file that is buggy, since it worked before, and works on ShareLatex. Should I simply reinstall MacTeX? What is going on?

  • The problem is somehow related with flushend package. Test without it. – Sigur May 14 '15 at 17:52
  • I get different outputs with TL 2012, 2013 or 2014: only the most ancient one gives the correct one, with the text of the abstract below the heading. With TL2013 I get the text flush right at the same level as ABSTRACT, with TL2014 the same but with the spurious rule. If I remove the flushend package, I get the same output with all versions. – egreg May 14 '15 at 17:56
2

It seems that, by default, the flushend package activates the debug option.

Use, in the class,

\RequirePackage[nodebug]{flushend}

instead of loading it without options.

Here's what I get from

\PassOptionsToPackage{nodebug}{flushend}
\documentclass{actaspartae}
\usepackage{hyperref}

\begin{document}

\subjectarea{Science}

\title[Short Title For this Article]{This is a Long Title For This Sample  Article}

\author{Jane Student}
\affil{Department of Science}

\maketitle

\begin{abstract}
This is a short statement which describes the research that I did.
\end{abstract}

Some text to keep flushend happy.

\end{document}

where the initial instructions is equivalent to calling flushend with the nodebug option.

enter image description here


From flushend documentation:

enter image description here

  • please, do you agree with the edition? – Sigur May 14 '15 at 18:13
  • This fixed it up perfectly! – SteelAngel May 14 '15 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.