This is the MacOS's Texshop disappearing apostrophe problem.

% !TEX encoding = UTF-8 Unicode

is added to the document preamble.

Within the program:

Preferences=>Source is set to UTF8.

Preferences=>Misc has pTex support unchecked (this solved the problem for many, but not for me.


Edit=>Substitutions none are checked.

I have tried ' and ’ (prime and option-shift-right bracket) but the latter should always yield apostrophes but it doesn't.


% !TEX encoding = UTF-8 Unicode
\usepackage[normalem]{ulem}  %for strikeout text
\usepackage{idxlayout} %%to fix issues with index



Joe’s shoes are missing. 
So are Sam's.
The person's shoes.

  • "Package inputenc Error: Keyboard character used is undefined (inputenc) in inputencoding `utf8' – Michael Kane May 17 '15 at 11:42

I had this exact problem recently! I tried two things:

  1. I added \usepackage[utf8]{inputenc}, with no success. I tried another, related package approach, but had no luck with that, either.
  2. I manually replaced the offending apostrophes with ones I typed freshly. This worked. To make this more efficient, you might consider doing a find-and-replace. This worked!

I also used XeLaTeX instead of LaTeX, for a related issue. It might be that if I had just used XeLaTeX from the beginning, I wouldn't have needed to manually fix all those apostrophes.

Lastly, the plural of apostrophe is apostrophes, without the apostrophe-s. ;)


You need to tell pdflatex that the source is utf8 as well. Add


at the top of the preamble.

  • Unfortunately, loading this package or utf8x didn't work. Instead, the following error message was produced: "Package inputenc Error: Keyboard character used is undefined (inputenc) in inputencoding `utf8' – Michael Kane May 17 '15 at 11:42
  • 1
    I'm stumped then - are you using an odd keyboard definition? The MWE you posted compiles without error at this end once I add the inputenc package as shown, and all the apostrophe's are visible. But then I use MacVim to edit, so it might be something specific to Texshop. – Thruston May 18 '15 at 9:34
  • Standard Mac OSX keyboard, no extra definitions. I think it's a Texshop problem as well. – Michael Kane Jun 1 '15 at 14:38
  • Same behavior in Texworks, so it's not a problem restricted to Texshop. – user26732 Dec 6 '15 at 6:13
  • As the comments show, none of the answers consistently resolve the problem which others have had. Manually retyping all the apostrophes in a 500+ page document is not really a solution. – user26732 Dec 13 '15 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.