3

I have an issue trying to set my margins on LyX. I am using a two-sided document, the box for this option is checked. I've set the value of inner margins (4cm) and outer margins (2cm), but on my Pdf I always have my 4 cm margin on the left and the 2cm one on the right...

Any Idea?

Thank you!

3

enter image description here

Menu DocumentConfigurationDocumment classOption class ⇢ Write here the twoside option, so after fix the margins, the LaTeX source show something like this:

\documentclass[twocolumn,english,twoside]{article}
...
\usepackage{geometry}
\geometry{verbose,lmargin=4cm,rmargin=2cm}

Then add some content and voilá.

If you want reproduce this minimal working example (MWE), it is a default document (article) with an ERT box (Ctrl+L) with \lipsum[1-50] to make the dummy text. This need the package lipsum: DocumentConfigurationLaTeX preamble ⇢ Write \usepackage{lipsum}. So this simple document:

enter image description here

will produce this LaTeX source:

%% LyX 2.1.2 created this file.  For more info, see ttp://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[twocolumn,english,twoside]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{geometry}
\geometry{verbose,lmargin=4cm,rmargin=2cm}
\makeatletter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% LyX specific LaTeX commands.
\providecommand{\LyX}{L\kern-.1667em\lower.25em\hbox{Y}\kern-.125emX\@}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\usepackage{lipsum}
\makeatother
\usepackage{babel}
\begin{document}
\title{Made with \LyX{}}
\maketitle
\lipsum[1-50]
\end{document}
  • The thing is I have already written my whole 50 pages work report, including floats and many other items ... – Gautier May 17 '15 at 21:25
  • I manages to fix it. There was a class document, inwhich was wrtitten twoside=semi. I editted it and wrote: twoside=on. Thank you for your answers! – Gautier May 17 '15 at 21:56
2

From

"Document" --> "Setting" ---> "Page Layout"

then click checkbox

"Two-sided document".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.