0

I am new to xelatex and use TeXstudio 2.9.4 with MiKTeX 2.9 !

I've recently upgraded from pdflatex to xelatex, due to the easy handling of new fonts in xelatex.

But the new problem I am facing is with .eps files. I have a number of graphs in .eps format, which xelatex is not showing in output .pdf file. Besides that, code is compiled successfully but without any graphs.

I did google out the issue but didn't get successful. One way I found, is to use the .pdf image of the .eps image which epstopdf had generated earlier. However, it is cumbersome if the graphs are large in number and get changed from time to time.

Any remedy to cope the issue will be very helpful to me. I am on TeXstudio 2.9.4 and using txs:///xelatex as my default compiler.

    \documentclass[11pt,final,onecolumn]{IEEEtran}
\usepackage{graphicx}
\usepackage[cmex10]{amsmath}
\interdisplaylinepenalty=2500
\usepackage{amssymb}
\usepackage{amsfonts}
\usepackage{caption}
\usepackage{subcaption}
\usepackage[noadjust]{cite}
\usepackage{epstopdf}
\usepackage{showkeys}
\usepackage{fontspec}
\pagebreak
\ifCLASSINFOpdf
\else
\fi
\hyphenation{}

\begin{document}
\title{Minimal Example}
\maketitle

 \begin{figure}[!h]
  \centering
   \captionsetup{justification=centering}
  \includegraphics[width=4.5in]{fig.eps}
  \caption{data-set $ z_3. $}
  \label{F1}
  \end{figure}    

\end{document}

The following warnings are displayed:

** WARNING ** No image converter available for converting file "C:/Users/Hawk/Desktop/fig.eps" to PDF format. ** WARNING ** >> Please check if you have 'D' option in config file. ** WARNING ** pdf: image inclusion failed for "fig.eps". ** WARNING ** Failed to read image file: fig.eps ** WARNING ** Interpreting special command PSfile (ps:) failed. ** WARNING ** >> at page="26" position="(162, 488.22)" (in PDF) ** WARNING ** >> xxx "PSfile="fig.eps" urx=448.3

These are the settings I made for xelatex to work in TeXstudio: enter image description here

  • 1
    Please provide more information about your document. Preferably providing a minimal example showing the smallest compilable document you can provide where including an .eps is a problem. Are you sure you are not under, say, draft mode? – daleif May 15 '15 at 7:05
  • 1
    Still no problem when I replace fig.eps with one I already have. Exactly which system are you on? Why exactly are you using xelatex, does IEEE allow xelatex? – daleif May 15 '15 at 8:12
  • 1
    Texstudio is not relevant. Which LaTeX dist? (I'm using TeX Live 2014 frozen) And again, does IEEE allow you to use special fonts? That dont may not be available in IEEEs production setup, thus your work might be in vain. Do you get any errors or warnings. – daleif May 15 '15 at 8:56
  • 1
    You might want to add that warning to the original question and hope for someone with more knowledge about xelatex to come along. Is that specific fig.eps available anywhere? Have you tried manually converting it to PDF via the commandline? (epstopdf fig.eps). It might be the EPS that has errors. Many of the converters are very specific. – daleif May 15 '15 at 9:17
  • 1
    @daleif Finally got successful to run xelatex and lualatex (and pdflatex too), based on your comments. I did first uninstall both MiKTex and Texstudio, and then I install TeX Live and Texstudio. Done ! – kaka May 18 '15 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.