1

I am making my CV using class moderncv. But each time that I try to compile, there is only a small black square (size depending on the thickness of the photo's border) instead of my photo.

Here is what appears

The photo is put in the right file and I've tried with and without the extension. But it still doesn't work. I've also noticed that the phone and address logos don't appear.

I thought this was because of the way I'm compiling: I'm using TeXnicCenter and always choose the LateX>PS>PDF compilation, but when I'm trying the Latex>PDF or LateX>DVI>PDF compilations, the PDF doesn't appear at all.

I've tried to compile with TeXmaker too, but I have the same problems.

Here is my code. Everything else is working, it's really just a problem with the photo and symbols for address and phone:

 \documentclass[10pt,a4paper,sans]{moderncv} 

 \moderncvtheme[black]{classic}

 \setlength{\hintscolumnwidth}{3cm} 

 \usepackage[latin1]{inputenc}    
 \usepackage[french]{babel}  
 \usepackage[top=1.1cm, bottom=1.1cm, left=2cm, right=2cm]{geometry}

 \renewcommand*{\namefont}{\fontsize{28}{20}\mdseries\upshape}
 \firstname{\huge Me} 
 \familyname{\huge Nom} 
 \social[linkedin][lala]{/lala}
 \title{Student} 
 \address{rue XX,  XX}{XX} 
 \mobile{+33~XX}
 \phone{+33~XX} 

 \email{[email protected]} 
 \extrainfo{Femme, 23 ans} 
 \photo[70pt][0.5pt]{lala}  
 \quote{Canditure}{}
 \begin{document}
 \maketitle
 \section{Formation}
 \cventry{Août à Juillet}{DD}{Ecole}{}{}{Mécanique}
 \cventry{Septembre à Juillet}{Cycle}{Université }{}{}{Matériaux}
 \cventry{Septembre à Juin}{Tronc}{Université}{}{}{Cycle}
 \cventry{Juin}{Bac S}{Lycée}{}{}{Mention}
 \section{Expérience Professionnelle}
 \cventry{Février à Décembre}{Projet de Fin d'Etudes}{Ecole}{SP}{Fr}{lalala}
 \cventry{Septembre à Février}{Stage}{Entreprise}{Clermont-Ferrand}{France}{loulou}
 \cventry{Février 2010}{Stage Ouvrier}{Entreprise}{Paris}{France}{Découverte}

 \section{Compétences}

 \subsection{Langues}
 \cvlanguage{Anglais}{lu, parlé, écrit}{niveau}
 \cvlanguage{Portugais}{lu, écrit, parlé}{niveau}
 \cvlanguage{Espagnol}{lu, parlé, écrit}{niveau}
 \cvlanguage{Allemand}{notions}{niveau}
 \subsection{Informatique}
 \cvcomputer{Simulation numérique}{lala} {Conception}{lala}
 \cvcomputer{Web}{lala}{Langage}{lala}
 \cvcomputer{Autre}{lala}{}{}
 \section{Divers}
 \cvline{Associatif}{lala}
 \cvline{Loisirs}{lala}

 \end{document}
4
  • Replacing "lala" with one of my images "images/rabbit.jpg" worked fine. Use unix style pathnames and include the extension. Commented May 16, 2015 at 3:39
  • I've just tried it, it did change the size of the square but I still can't see the picture. I've changed the photo and the extension to try, but it doesn't work. And I still can't compile using (Latex>PDF) directly or (Latex>DVI>PDF)
    – Mess
    Commented May 17, 2015 at 20:25
  • What sort of image is lala anyway? Commented May 17, 2015 at 23:05
  • It's a photo of myself on png or jpg formar (I've tried both formats). i need to put it on my resume to apply for a job.
    – Mess
    Commented May 18, 2015 at 9:32

1 Answer 1

3

As I said, it worked fine for me:

\photo[70pt][0.5pt]{images/rabbit.jpg}  

photo test

3
  • Hm well I don't understand then, because when I'm using Latex for another document, the pictures appear without any problem but when I'm using moderncv there is nothing. What do you use to compile? TeXnicCenter? Texmaker? Another?
    – Mess
    Commented May 18, 2015 at 14:23
  • TexnicCenter and MikTeX. Is lala.jpg in the same folder as the tex file? Commented May 18, 2015 at 15:06
  • Yes it is and I'm also using TexnicCenter and MikTeX. I think that my problem comes from the fact that I'm compiling with (Latex>PS>PDF), so I'm trying to see why I'm getting a "fatal error" each time it's creating the PDF using (Latex>PDF) directly. I'm using Sumatra PDF now and I've tried to change the DDE command on the viewer but I still can not open the file.. I'll try to see here if there isn't another subject about that issue. Thanks for your help
    – Mess
    Commented May 18, 2015 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .