4

I would like quite a long quote before my chapter title, a need which is perfectly fulfilled by using the \epigraphhead command provided with the epigraph package.

However, because the quote is very long, it interferes with my chapter title and text, like so:

enter image description here

In the documentation it is mentioned that this is likely to happen with long quotes, and that one can use the \dropchapter command to lower the chapter title, followed by the \undodrop command to make sure that the subsequent chapter titles are set normally again.

This is where my problem arises. Consider the following MWE (MWE1):

\documentclass[11pt]{report}
\usepackage[bottom=2cm, top=2cm, left=3cm, right=2cm]{geometry}
\usepackage{epigraph}

\usepackage{lipsum}

\begin{document}

\dropchapter{15cm}
\chapter*{Introduction}
\epigraphhead[200]{\lipsum[1]}
\lipsum[1-3]
\undodrop

\chapter*{Method}
\lipsum[4-6]
\end{document}

This still produces the following: enter image description here

In other words, nothing happens.

Now consider the following MWE (MWE2):

(note that the only difference with MWE1 is that the \chapter*{} commands have been changed to regular \chapter{} commands)

\documentclass[11pt]{report}
\usepackage[bottom=2cm, top=2cm, left=3cm, right=2cm]{geometry}
\usepackage{epigraph}

\usepackage{lipsum}

\begin{document}

\dropchapter{15cm}
\chapter{Introduction}
\epigraphhead[200]{\lipsum[1]}
\lipsum[1-3]
\undodrop

\chapter{Method}
\lipsum[4-6]
\end{document}

This produces the following output:

enter image description here

In other words, this is exactly what I need.

So I've already narrowed down where the problem arises (the \chapter*{} command), but I can't seem to figure out how to make the \dropchapter command work with MWE1. It is MWE1 that I want to use, I don't want the "Chapter X" prefixes in my document.

Does anyone have the answer? Thank you very much in advance!

2

The epigraph package uses a horrible hack for realizing \dropchapter: it adds a vertical space in \@chapapp, which is not used when \chapter* is executed.

Here's a version that's specific for book and report (other classes may have different \@makechapterhead and \@makeschapterhead commands), but it works for both starred and unstarred \chapter commands.

\documentclass[11pt]{report}
\usepackage[bottom=2cm, top=2cm, left=3cm, right=2cm]{geometry}
\usepackage{epigraph}
\usepackage{etoolbox}

\usepackage{lipsum}

\makeatletter
\newlength{\@epidrop}
\newcommand{\@epidropdefault}{50\p@} % the default in report
\patchcmd{\@makechapterhead}{50\p@}{\@epidrop}{}{}
\patchcmd{\@makeschapterhead}{50\p@}{\@epidrop}{}{}
\renewcommand{\dropchapter}[1]{\setlength{\@epidrop}{#1}}
\renewcommand{\undodrop}{\dropchapter{\@epidropdefault}}
\undodrop
\makeatother

\begin{document}

\dropchapter{15cm}

\chapter*{Introduction}
\epigraphhead[200]{\lipsum[1]}
\lipsum[1-3]

\chapter{Introduction}
\epigraphhead[200]{\lipsum[1]}
\lipsum[1-3]
\undodrop

\chapter{Method}
\lipsum[4-6]
\end{document}

This works by substituting the vertical space hardwired in \@makechapterhead and \@makeschapterhead with a length parameter that we can control with a redefinition of \dropchapter.

Of course, using short epigraphs is the best solution.

enter image description here

  • Thank you so much, it works like a charm! I would've never figured this out on my own. – idix May 15 '15 at 18:29
0

For KOMA-script classes, egreg's answer doesn't work. Instead one can use

\renewcommand{\chapterheadstartvskip}{\vspace{15cm}}

Full example:

\documentclass{scrbook}
\usepackage{epigraph}

\let\defaultchapterheadstartvskip\chapterheadstartvskip
\renewcommand{\dropchapter}[1]{ 
  \renewcommand{\chapterheadstartvskip}{\vspace{#1}}
}
\renewcommand{\undodrop}[0]{
  \renewcommand{\chapterheadstartvskip}{\defaultchapterheadstartvskip}
}

\usepackage{lipsum}

\begin{document}


\dropchapter{15cm}
\chapter{Introduction}
\epigraphhead[200]{\lipsum[1]}
\lipsum[1-3]
\undodrop

\chapter{Method}
\lipsum[4-6]
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.