2

In a presentation I am currently working on, I would like to have all citations look like

[LastNameOfFirstAuthor et al. 1999]

where 1999 is the year and the "et al." only shows up for multiple authors. In same cases (namely the ones where I am talking about my papers and I am not first author), I would like to have it like

[LastNameOfFirstAuthor, LastNameOfSecondAuthor, MyLastName et al. 1999]

I tried to achive this behaviour with these settings:

\usepackage[url=false,citestyle=authoryear,block=ragged,backend=biber,
            maxalphanames=1,maxcitenames=1,indexing=true]{biblatex}

plus overriding the cite command like

\let\ORIGcite=\cite
\renewcommand{\cite}[2][1]{%
  \AtNextCite{\defcounter{maxnames}{#1}\defcounter{minnames}{#1}}
  \footnotesize[\ORIGcite{#2}]%
}

The latter part seems to be working fine, but if you have an author that is cited multiple times (with different works), the maxcitenames setting is ignored.

Even explicitly setting the number of authors \cite\[1\]{...} does not help.

Here comes a MWE (hope the formatting is not too bad)

\documentclass[noshadow]{beamer}
\usepackage{filecontents}
\RequirePackage[url=false,citestyle=authoryear,block=ragged,backend=biber,maxcitenames=1,indexing=true]{biblatex}
\addbibresource{\jobname.bib} 
\begin{filecontents}{\jobname.bib}
@InProceedings{b,
  Title                    = {BBB},
  Author                   = {Justin For and Compa Rison},
  Year                     = {1999}
}
@PhdThesis{a,
  Title                    = {AAA},
  Author                   = {Some Name},
  Year                     = {2002},
}
@InProceedings{c,
  Title                    = {CCC},
  Author                   = {Some Name and Second Author},
  Year                     = {2012},
}
\end{filecontents}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\begin{document}
\section{Slide 1}
\begin{frame}
    \cite{c}\\
    \cite{b,a}
\end{frame}
\begin{frame}{Literature}
    \printbibliography
\end{frame}
\end{document}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

This produces

Name and Author 2012
For et al. 1999; Name 2002

but should produce

Name et al. 2012           <---
For et al. 1999; Name 2002

I'd appreciate any help on this question.

I guess this question, this and this are related to this one; but they didn't help here.

3

OK, I found the solution myself. This seems to be connected to the uniquelist=false setting. More details can be found here

Set limit to one author when using "et al." in biblatex

However, it seems weird to me, because in the example I gave, the keys would be unique (given the different publication year and the "et al." - where the latter might not count).

0

The idea embedded in your original question helped me. I'll extract it and clean it up a little, here:

\newcommand{\citefirst}[1]{%
  \AtNextCite{\defcounter{maxnames}{1}\defcounter{minnames}{1}}%
  \citet{#1}%
}

If you only want to cite the author, replace the \citet with \citeauthor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.