66

I have a document that uses twocolumn with scrbook. How can I set the width of the space between the two columns?

1
  • Why was there a -1 vote?
    – raphink
    Commented Feb 29, 2016 at 20:25

3 Answers 3

80

Use \setlength{\columnsep}{<width>} in the preamble of your document, i.e. before \begin{document}.

Changing \columnsep also works if you use the multicol package.

3
  • 3
    I used \setlength{\columnsep}{5 in} but it didn't make any difference. I'm a beginner to latex. I think there's a problem with dimensions. Please help.
    – meteors
    Commented Aug 27, 2013 at 5:00
  • 1
    In the case of the multicol package, the \setlength command need not necessarily appear in the preamble; it can appear inside the body as well, as long as it precedes the \multicols or multicols* environment that it is intended to apply to. Consider, for instance, a document with two \multicols environments. These environments can have different inter-column spaces, but then the \columnsep parameter must be set inside the body.
    – Evan Aad
    Commented Jun 11, 2017 at 9:19
  • 3
    Thank you, but no matter where in the document I set it—in the preamble, in the body, before the environment, after the environment (which wouldn't make sense anyway, but I tried it just in case)—this command has no effect on my document. The columns always stay quite far apart. Nor does setting the width make a difference, as suggested by Muaz Khan below. I am using \begin{multicols}{3}. Commented Sep 25, 2017 at 11:54
4

I ran into this problem earlier today. As Mauz Khan and Evan Aad note, the solution of adding \setlength{\columnsep}{<width>} to the preamble or in the body (prior to starting the multicol environment) does not always work. If you are in certain modes (Beamer, for instance) where \usepackage{multicol} is being called in your .sty file (rather that in the preamble of your actual document), modifying \columnsep in your document's preamble will not work. In this case, you would need to modify the length in the preamble of the .sty file by adding \setlength{\columnsep}{<width>} there instead, rather than in your document.

I hope this helps someone else! Perhaps its more of a comment, but this is what I am limited to.

4
  • Welcome to TeX.SX! This is more of a comment rather than an answer.
    – TeXnician
    Commented Mar 24, 2018 at 15:31
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review
    – Bobyandbob
    Commented Mar 24, 2018 at 20:25
  • Hi @Bobyandbob, I think it is worth leaving here because the accepted answer will not work in all cases, as I have noted above. Sorry for the ambiguity!
    – NWaters
    Commented Mar 24, 2018 at 22:55
  • If you set it to a negative value, e.g. \setlength{\columnsep}{-3.0mm} it should work.
    – Tony Power
    Commented Dec 7, 2018 at 13:41
3

As meteors mentioned in his comment, \setlength{\columnsep}{5 in} also did not work for me. I was using \twocolumn command. Instead of separating the two column, I adjusted the widths of each column and it did work out well i.e.,

\setlength{\columnwidth}{<width>}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .